Bug 98945 - top segmentation faults under heavy load
top segmentation faults under heavy load
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-10 14:53 EDT by gerry.morong
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-11 15:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gerry.morong 2003-07-10 14:53:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; compaq)

Description of problem:
After upgrading from kernel from 2.4.18-24.7.smp to 2.4.20-18.7.smp, top will 
segmentation fault after several house on a loaded system.

Version-Release number of selected component (if applicable):
2.0.7-12

How reproducible:
Always

Steps to Reproduce:
1.Load up 4 CPU system system to achieve about 4.0 load average
2.Run top with no options
3.Leave it running for several hours until a segmentation fault is reported.
    

Actual Results:  Top stops with a segmentation fault

Expected Results:  Top should continue running

Additional info:
Comment 1 gerry.morong 2003-07-11 15:36:09 EDT
Looks like the newer procps-2.0.11-6 once rebuilt works great.

Note You need to log in before you can comment on or make changes to this bug.