Bug 989460 - It display blank page after add skip_maven_build marker to a jboss app & git push back
It display blank page after add skip_maven_build marker to a jboss app & git ...
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 06:07 EDT by weiwei jiang
Modified: 2016-10-30 18:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 12:57:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description weiwei jiang 2013-07-29 06:07:48 EDT
Description of problem:
Add a skip_maven_build marker to a jboss app and then git push back, then access the app URL, it display blank page.

Version-Release number of selected component (if applicable):
INT(devenv_3569)

How reproducible:
always

Steps to Reproduce:
1.Create a jboss app via jbosstool or rhc 
2.Add skip_maven_build marker to the app
  run `touch .openshift/markers/skip_maven_build`
3.git push & access the app URL 

Actual results:
git push successfully & got blank page 

Expected results:
git push successfully & app page display well

Additional info:
the status of the app is started
Comment 1 Dan Mace 2013-07-29 14:58:53 EDT
Closing this one.

When using skip_maven_build marker, the app developer must implement a new build or commit archived deployments to the Git repository. During the app create, a "default" WAR (which is analogous the product of a maven build using the default pom.xml provided with the app's Git template) is present. If you add the skip_maven_build marker without replacing the build system you're now skipping, the previously built (and now deleted) artifacts are never recreated.
Comment 3 Oleg Fayans 2013-11-13 09:38:33 EST
Did you change this behavior? Because now, when I add a skip_maven_build marker and do git push, the app still displays the old (non-empty) content
Comment 4 Dan Mace 2013-11-13 12:57:36 EST
With the new build/deploy system, previously built 'dependencies' (e.g. ROOT.war in the original QE example) are not purged unless force clean build is specified.

What happens when the app repo is cleaned and replaced from git and then re-deployed absent a Maven build is dependent upon the specific application details (e.g. if the app consisted of static resources not packaged by Maven, then skipping the Maven build wouldn't be expected to have any effect).

The system is working as designed, and so I'm closing this. Feel free to reach out on IRC or email with any further requests for clarification on the build/deploy behavior.

Note You need to log in before you can comment on or make changes to this bug.