Bug 989464 - spec fixes needed for package cleanup
spec fixes needed for package cleanup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvoikko (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ville-Pekka Vainio
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 06:14 EDT by Parag AN(पराग)
Modified: 2013-08-26 18:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: libvoikko-3.6-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 18:28:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec fixes to follows current packaging guidelines (3.04 KB, patch)
2013-07-29 06:14 EDT, Parag AN(पराग)
no flags Details | Diff

  None (edit)
Description Parag AN(पराग) 2013-07-29 06:14:59 EDT
Created attachment 779744 [details]
spec fixes to follows current packaging guidelines

Description of problem:
Following issues are being fixed in attached patch
1) Package contains BR: python2-devel or python3-devel
  See: http://fedoraproject.org/wiki/Packaging:Python#BuildRequires

2) Fully versioned dependency in subpackages is not present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in libvoikko-
     devel , voikko-tools , python-libvoikko

3)  %defattr present but not needed

4) fixes rpmlint messages
libvoikko.src:13: W: macro-in-comment %{name}
libvoikko.src:13: W: macro-in-comment %{version}

5) python_sitelib macro is not needed
https://fedoraproject.org/wiki/Packaging:Python#Macros

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
I will build this in master.
Comment 1 Parag AN(पराग) 2013-07-29 06:17:10 EDT
Please fix this in f19 also.
Comment 2 Fedora Update System 2013-08-05 04:12:03 EDT
libvoikko-3.6-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libvoikko-3.6-3.fc19
Comment 3 Fedora Update System 2013-08-05 20:18:01 EDT
Package libvoikko-3.6-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvoikko-3.6-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14275/libvoikko-3.6-3.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-26 18:28:00 EDT
libvoikko-3.6-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.