Bug 989475 - sosreport should collect /var/run/gluster* also as it has geo-replication related log/files
sosreport should collect /var/run/gluster* also as it has geo-replication rel...
Status: CLOSED DUPLICATE of bug 1022523
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: sos (Show other bugs)
2.1
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 06:42 EDT by Rachana Patel
Modified: 2015-04-20 07:56 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-31 23:31:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-29 06:42:55 EDT
Description of problem:
sosreport should collect /var/run/glusterfs also as it has geo-replication related log/files

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
sosreport does not pick /var/run/gluster*

Expected results:


Additional info:
Comment 2 Bryn M. Reeves 2013-07-29 07:36:43 EDT
What sort of size are we looking at for these files? Depending on the answer it may be worth enabling either default or optional size-limits for this collection.
Comment 3 Bala.FA 2013-08-16 02:01:32 EDT
I believe /var/run is meant for daemon state file like pid.  Why logs go into /var/run/gluster* directory?
Comment 4 Venky Shankar 2013-08-16 02:36:53 EDT
(In reply to Bala.FA from comment #3)
> I believe /var/run is meant for daemon state file like pid.  Why logs go
> into /var/run/gluster* directory?

Geo-Replication uses /var/run/gluster/ as a working directory which hold processed changelogs. There is one log file generated by geo-replication (libgfchangelog.so to be precise).

I'll change that to generate log file in the standard log file directory. Collecting /var/run/gluster/ will be a good idea anyway in order to debug geo-replication changelog issues.
Comment 5 Amar Tumballi 2013-08-19 02:44:41 EDT
/var/run/gluster is for keeping any 'state' information. Ie, anything used by the process while its running. (pid is one of such state info). log here is not logging of msgs, but the 'changelog' as Venky rightly said. So please collect /var/log/gluster
Comment 6 Bryn M. Reeves 2014-06-20 06:56:50 EDT
I don't see a corresponding RHEL bug for this RFE. What's the status? It's easy enough for us to add this to sos but I'd like to see some examples of the files / directory structure that we should expect.
Comment 7 Aravinda VK 2014-12-31 23:31:26 EST
I updated the working dir location in bz 1022523. Closing this bug as duplicate.

*** This bug has been marked as a duplicate of bug 1022523 ***

Note You need to log in before you can comment on or make changes to this bug.