Bug 989493 - Failed manually set SPM Priority - Field sshPort can not be updated when status is Up
Failed manually set SPM Priority - Field sshPort can not be updated when stat...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Yaniv Bronhaim
yeylon@redhat.com
infra
:
: 990081 (view as bug list)
Depends On:
Blocks: 867642 1019461
  Show dependency treegraph
 
Reported: 2013-07-29 07:31 EDT by vvyazmin@redhat.com
Modified: 2016-04-18 02:52 EDT (History)
10 users (show)

See Also:
Fixed In Version: is9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:14:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm (2.81 MB, application/x-gzip)
2013-07-29 07:31 EDT, vvyazmin@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17303 None None None Never
oVirt gerrit 17429 None None None Never
oVirt gerrit 18628 None None None Never

  None (edit)
Description vvyazmin@redhat.com 2013-07-29 07:31:32 EDT
Created attachment 779804 [details]
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm

Description of problem:
Failed manually set SPM Priority - Field sshPort can not be updated when status is Up

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS7 environment:

RHEVM: rhevm-3.3.0-0.11.master.el6ev.noarch
VDSM: vdsm-4.12.0-rc3.12.git139ec2f.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.355.el6_4.5.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64
PythonSDK: rhevm-sdk-python-3.3.0.7-1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
Create Data Center with tree hosts connected to two Storage Domains. 
Manually edit “SPM Priority” to Low or High

Actual results:
Failed set “SPM Priority”

Expected results:
Succeed set “SPM Priority”

Impact on user:
Failed set “SPM Priority”

Workaround:
none

Additional info:
UI:
Error while executing action:

tigris02.scl.lab.tlv.redhat.com:
Cannot edit Host. Host parameters cannot be modified while Host is operational.
Please switch Host to Maintenance mode first.

/var/log/ovirt-engine/engine.log
2013-07-29 13:49:34,230 WARN  [org.ovirt.engine.core.compat.backendcompat.PropertyInfo] (ajp-/127.0.0.1:8702-1) Unable to get value of property: vdsName for class org.ovirt.engine.core.common.businessentities.VdsStatic
2013-07-29 13:49:34,230 WARN  [org.ovirt.engine.core.compat.backendcompat.PropertyInfo] (ajp-/127.0.0.1:8702-1) Unable to get value of property: vdsName for class org.ovirt.engine.core.common.businessentities.VdsStatic
2013-07-29 13:49:34,230 ERROR [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-1) Field sshPort can not be updated when status is Up
2013-07-29 13:49:34,230 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-1) ObjectIdentityChecker.IsUpdateValid:: Not updatable field 'sshPort' was updated
2013-07-29 13:49:34,230 WARN  [org.ovirt.engine.core.bll.UpdateVdsCommand] (ajp-/127.0.0.1:8702-1) CanDoAction of action UpdateVds failed. Reasons:VAR__ACTION__UPDATE,VAR__TYPE__HOST,VDS_STATUS_NOT_VALID_FOR_UPDATE

/var/log/vdsm/vdsm.log
Comment 1 Yaniv Bronhaim 2013-07-29 11:47:18 EDT
When setting the spm priority we update all vds related raw in vdsStatic table, part of this raw is sshPort field that could be updated when vds is in UP state (fix in http://gerrit.ovirt.org/17429).

The reason it was not raised before is that the VDS was probably added before we added this fields with the new update script, we added sshPort field with null, instead of giving it default value. When ssh port is null the backend uses 22 as default, when setting another field as SPM priority (it could happened with other fields as well), the set of 22 is recognized as an update and that fails the update operation at all. The patch (http://gerrit.ovirt.org/17303) set default values for sshPort and sshUsername to avoid such issues.
Comment 2 Yaniv Bronhaim 2013-08-04 04:24:03 EDT
*** Bug 990081 has been marked as a duplicate of this bug. ***
Comment 3 vvyazmin@redhat.com 2013-08-18 15:19:31 EDT
Tested on FCP Data Center

Verified, tested on RHEVM 3.3 - IS10 environment:

RHEVM:  rhevm-3.3.0-0.15.master.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.10-1.el6ev.noarch
VDSM:  vdsm-4.12.0-61.git8178ec2.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.355.el6_4.5.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64
Comment 7 Itamar Heim 2014-01-21 17:14:14 EST
Closing - RHEV 3.3 Released
Comment 8 Itamar Heim 2014-01-21 17:22:01 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.