Bug 989494 - ocf:redhat:lvm.sh stopped creating resource
ocf:redhat:lvm.sh stopped creating resource
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Feist
: Regression
Depends On:
Blocks: 990025
  Show dependency treegraph
 
Reported: 2013-07-29 07:32 EDT by michal novacek
Modified: 2013-11-21 06:52 EST (History)
3 users (show)

See Also:
Fixed In Version: pcs-0.9.80-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 06:52:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michal novacek 2013-07-29 07:32:01 EDT
Description of problem:
It's not possible to create resource with ocf:redhat:lvm.sh 

Version-Release number of selected component (if applicable):
resource-agents-3.9.2-25.el6.x86_64
RHEL 6.5-20130728.n.0

How reproducible: always

Steps to Reproduce:
1. pcs resource create halvm ocf:redhat:lvm.sh

Actual results: error, resource not created

Expected results: resource created

Additional info:
# pcs status
Cluster name: 
Last updated: Mon Jul 29 13:15:11 2013
Last change: Mon Jul 29 12:52:47 2013 via cibadmin on virt-128.cluster-qe.lab.eng.brq.redhat.com
Stack: cman
Current DC: virt-129.cluster-qe.lab.eng.brq.redhat.com - partition with quorum
Version: 1.1.10-2.el6-368c726
3 Nodes configured
1 Resources configured

Online: [ virt-128 virt-129 virt-130 ]

Full list of resources:

 virt-fencing   (stonith:fence_xvm):    Started virt-128 

# pcs resource describe ocf:redhat:lvm.sh
Resource options for: lvm.sh
  name: Unique name for this LVM resource
  vg_name (required): Name of the volume group being managed
	...
# pcs resource create halvm ocf:redhat:lvm.sh 
Error: Unable to find resource: ocf:heartbeat:lvm.sh

Does it somehow relate to obsoleting this resource with rewritten ocf:heartbeat:LVM by any chance?
Comment 1 michal novacek 2013-07-29 07:33:09 EDT
Marking regression as this works in RHEL6.4
Comment 4 David Vossel 2013-07-29 10:37:18 EDT
(In reply to michal novacek from comment #1)
> Marking regression as this works in RHEL6.4

Both the symlink, /usr/lib/ocf/resource.d/redhat, and the agent, /usr/share/cluster/lvm.sh, exist in the rpm you are testing.  I'm doubtful that this involves the lvm.sh agent.

Try updating pcs, if that doesnt' work move this issue to the pcs component and Chris will likely know what is going on.

-- Vossel
Comment 5 michal novacek 2013-07-29 10:56:11 EDT
The latest version of pcs I found was 0.9.56 and the behaviour did not change:

# rpm -q pcs 
pcs-0.9.59-1.el6.noarch

# pcs resource create halvm ocf:redhat:lvm.sh
Error: Unable to find resource: ocf:heartbeat:lvm.sh

Re-assigning component to pcs as for comment #4
Comment 6 Chris Feist 2013-07-29 15:02:52 EDT
Found this issue, this has been fixed here:

https://github.com/feist/pcs/commit/5e56839ef593ffc4f5cb39b17584eedc60d114c7

New build will be coming shortly.
Comment 7 Chris Feist 2013-07-29 18:04:55 EDT
[root@ask-02 ~]# rpm -q pcs
pcs-0.9.59-1.el6.noarch
[root@ask-02 ~]# pcs resource create halvm9 ocf:redhat:lvm.sh
Error: Unable to find resource: ocf:heartbeat:lvm.sh

...  Install new version ...

[root@ask-02 ~]# rpm -q pcs
pcs-0.9.60-1.el6.noarch
[root@ask-02 ~]# pcs resource create halvm9 ocf:redhat:lvm.sh
[root@ask-02 ~]# pcs resource show halvm9
 Resource: halvm9 (class=ocf provider=redhat type=lvm.sh)
  Operations: monitor interval=60s (halvm9-monitor-interval-60s)
Comment 11 Chris Feist 2013-09-09 18:38:44 EDT
This should be fixed:

[root@ask-02 pcs]# rpm -q pcs
pcs-0.9.80-1.el6.noarch
[root@ask-02 pcs]# pcs -f temp.xml resource create TEST ocf:redhat_old:lvm.sh
Error: Unable to create resource 'ocf:redhat_old:lvm.sh', it is not installed on this system (use --force to override)
Comment 13 errata-xmlrpc 2013-11-21 06:52:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1633.html

Note You need to log in before you can comment on or make changes to this bug.