Bug 989534 - yum fixups
yum fixups
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.2
Assigned To: Alon Bar-Lev
Pavel Stehlik
integration
: ZStream
Depends On: 989235
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 09:24 EDT by Chris Pelland
Modified: 2013-08-13 09:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Various fixes have been made to the yum API to enhance the upgrade process.
Story Points: ---
Clone Of: 989235
Environment:
Last Closed: 2013-08-13 09:09:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16805 None None None Never
oVirt gerrit 17108 None None None Never
oVirt gerrit 17326 None None None Never

  None (edit)
Description Chris Pelland 2013-07-29 09:24:48 EDT
+++ This bug was initially created as a clone of Bug #989235 +++

This is per 3.2.z, fixups we found in yum api to support better upgrade.

--- Additional comment from Alon Bar-Lev on 2013-07-28 11:25:07 EDT ---

commit ee663bd7fc99e30dab42b6360172cabcdf4e5aa0
Author: Alon Bar-Lev <alonbl@redhat.com>
Date:   Sun Jul 14 16:04:13 2013 +0300

    packaging: setup: sync miniyum with otopi
    
    1. add destructor to clean up yum base
    2. force clenaup state before rollback
    3. better method to query transaction
    4. more logging
    
    Change-Id: Ib963d8d66e9544bae3b37e8b2d85bdb2195b6c42
    Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>

--- Additional comment from Alon Bar-Lev on 2013-07-28 11:26:50 EDT ---

commit e85551d2630f1e3403ad99c68d83188b49c770df
Author: Alon Bar-Lev <alonbl@redhat.com>
Date:   Fri Jul 19 16:53:14 2013 +0300

    packaging: setup: ignore sack cache populate errors
    
    for some reason yum when going to cache only mode tries to download
    online repositories, and if fails cause the entire transaction to fail.
    
    more over, when going online, it also tries to download online
    resources, and if fails cause the entire transaction to fail.
    
    any network issue during this stage will create an undesired failure. so
    just ignore these errors and hope for the best, as this sequence is only
    used when transaction is rollbacked.
    
    Change-Id: I6f6cba0071da862addcb438d47ac9401f746ee87
    Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>

--- Additional comment from Alon Bar-Lev on 2013-07-28 11:27:53 EDT ---

commit 160ab4edb5b176e626fca4dd3e748e3397b01db0
Author: Alon Bar-Lev <alonbl@redhat.com>
Date:   Fri Jul 26 02:19:10 2013 +0300

    packagers: yum: do not use yum state strings
    
    the yum.i18n produces non standard string encoding, encoded using ansi
    codec but has unicode string, while the locale environment is set to
    unicode, and python does enforce proper unicode in string.format().
    
    the solution is to provide our own translation table for transaction
    status, as no [simple] way was found to convert the non standard format
    into unicode.
    
    Change-Id: If230a17799263e705f194f180af04bf2904a5d90
    Reported-By: Jakub Bittner <j.bittner@nbu.cz>
    Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>
Comment 3 errata-xmlrpc 2013-08-13 09:09:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1149.html

Note You need to log in before you can comment on or make changes to this bug.