Bug 989545 - The responsive navigation portlet is showing page node names to users without sufficient rights
The responsive navigation portlet is showing page node names to users without...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity unspecified
: ER01
: 6.1.1
Assigned To: Juraci Paixão Kröhling
Dominik Pospisil
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 09:47 EDT by Viliam Rockai
Modified: 2015-08-31 23:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 10:11:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GTNPORTAL-3213 Major Resolved The responsive navigation portlet is showing page node names to users without sufficient rights 2014-01-17 06:27:09 EST

  None (edit)
Description Viliam Rockai 2013-07-29 09:47:48 EDT
The responsive navigation portlet is showing page node names to users without sufficient rights.

When creating a new navigation, you can restrict access to some pages. The original navigation portlet won't show the page nodes which current user can't access, but the responsive navigation portlet shows everything.

more info:
https://community.jboss.org/message/830117
Comment 2 Boleslaw Dawidowicz 2013-11-19 06:13:19 EST
So actually despide the fact that related commit was merged int 3.6.x this issue seems to be still present

https://github.com/gatein/gatein-portal/commit/e046923a8d5f68552b27d4d841515a51575a981d
Comment 3 Juraci Paixão Kröhling 2013-11-20 09:09:03 EST
The commit is indeed on the right branch, and is fixing the described issue. Just to clarify, the behavior is:

- Pages which are restricted to the current user will not be shown on the navigation. 
- Pages which are public but contains only restricted portlets will be shown as "empty" (as the portlet won't be rendered), and the page will indeed be shown in the navigation. 

This is the current behavior for:
- master
- branch 3.6.x
- JPP 6.1.0.GA

Note You need to log in before you can comment on or make changes to this bug.