Bug 989582 - Macbook Air external speakers not working but headphones work
Macbook Air external speakers not working but headphones work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 11:03 EDT by Matt Hicks
Modified: 2014-03-10 11:04 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 11:04:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ALSA Info (40.58 KB, text/plain)
2013-07-29 11:03 EDT, Matt Hicks
no flags Details

  None (edit)
Description Matt Hicks 2013-07-29 11:03:29 EDT
Created attachment 779975 [details]
ALSA Info

Description of problem:

On a Macbook Air 2013 model running Fedora 19, the internal speakers don't produce any sound output.  Plugging in the headphones works fine however.

Hardware (ALSA Info attached): 

  $ lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)  

Version-Release number of selected component (if applicable):

Kernel:
  $ uname -a
Linux localhost.localdomain 3.10.3-300.fc19.x86_64 #1 SMP Fri Jul 26 00:00:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ rpm -qa | grep pulseaudio
pulseaudio-libs-glib2-3.0-10.fc19.x86_64
alsa-plugins-pulseaudio-1.0.27-1.fc19.i686
pulseaudio-module-x11-3.0-10.fc19.x86_64
pulseaudio-gdm-hooks-3.0-10.fc19.x86_64
kde-settings-pulseaudio-19-23.fc19.noarch
pulseaudio-libs-3.0-10.fc19.x86_64
pulseaudio-libs-3.0-10.fc19.i686
alsa-plugins-pulseaudio-1.0.27-1.fc19.x86_64
pulseaudio-libs-glib2-3.0-10.fc19.i686
pulseaudio-3.0-10.fc19.x86_64
pulseaudio-utils-3.0-10.fc19.x86_64
pulseaudio-module-bluetooth-3.0-10.fc19.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Boot
2. Turn sound to 100%.  Open Sound Settings
3. Test right speaker / left speaker

Actual results:
No sound.

Expected results:
Internal speaker sound.

Additional info:
Same test with headphones in works fine through the headphones.
Comment 1 Miek Gieben 2013-08-30 06:22:19 EDT
Runnnig 3.11-rc6 and seeing the same problem (on Ubuntu). Seems that after a suspend&resume cycle the headphones also cease to work.
Comment 2 Miek Gieben 2013-09-06 06:13:45 EDT
With 3.11 sound (via the headphones) keeps on working even after the resumes.
Comment 3 Josh Boyer 2013-09-18 16:25:42 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 4 Emmanuele Bassi 2013-09-25 08:59:33 EDT
I'm experiencing the same issue. also, jack sensing does not work.

Apple did a full HW refresh for the 2013 MacBook Air, so some devices are not recognised - including the Cirrus audio system.

kernel bug https://bugzilla.kernel.org/show_bug.cgi?id=60811 has a patch for Alsa that fixes the issue.
Comment 5 Emmanuele Bassi 2013-10-13 05:47:59 EDT
still happening with Fedora 20.
Comment 6 Alex Markley 2013-10-30 11:34:03 EDT
I've just put Fedora 19 on a MacBookAir6,2, and I can confirm this issue is happening for me too.
Comment 7 carasin 2013-12-14 13:42:00 EST
Fedora 20
kernel-3.12.5-301.fc20.x86_64
Lenovo Y470p
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

There is no sound via speakers after boot. But after plugging/unplugging the headphones (via 3,5 mm jack) the sound (via speakers) comes back. BTW, the headphones work fine.
Comment 8 Justin M. Forbes 2014-03-10 10:49:16 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.13.5-100.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 9 Emmanuele Bassi 2014-03-10 10:55:01 EDT
it seems 3.12.8-300 already fixed the issue for me: I get jack sensing, and the speaker works. I guess this bug can be closed.
Comment 10 Josh Boyer 2014-03-10 11:04:40 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.