Bug 989599 - [Doc] [RFE] Adding image multiple location support
[Doc] [RFE] Adding image multiple location support
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Administration_User_Guide (Show other bugs)
4.0
Unspecified Unspecified
medium Severity medium
: ---
: 6.0 (Juno)
Assigned To: Summer Long
ecs-bugs
https://blueprints.launchpad.net/nova...
upstream_milestone_icehouse-3 upstrea...
: Documentation, FutureFeature, Triaged
Depends On:
Blocks: 978504
  Show dependency treegraph
 
Reported: 2013-07-29 11:47 EDT by Stephen Gordon
Modified: 2014-11-24 01:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-24 01:06:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-07-29 11:47:00 EDT
Cloned for documentation impact, refer to Bug # 978504 for implementation details.
Comment 2 Summer Long 2013-08-13 00:37:23 EDT
Hi John, looks like you're almost finished with this implementation upstream. 
When you're finished, could you provide the details for doc'ing it?

I'm seeing this in the test plan. Is this still correct?
1) Install glance
2) add the following line to glance-api.conf

    show_multiple_locations = True

3) use glance client to 'show' an image with the v2 protocol:

 glance --os-image-api-version 2 image-show <image id>

Is there an impact in the dashboard as well?
thanks, Summer
Comment 3 Stephen Gordon 2013-09-24 13:42:30 EDT
Moving to Red Hat Enterprise Linux OpenStack 5 based on parent bug state.
Comment 4 Martin Lopes 2014-02-03 21:55:16 EST
This bug is being assigned to Summer Long, who is now the designated docs specialist for nova.
Comment 5 Summer Long 2014-04-28 23:59:32 EDT
Hi Flavio, the upstream blueprint says that it's been deferred to Juno. Is this correct? 
If it is indeed in Icehouse, can you respond to my questions in Comment 2?

thanks, Summer
Comment 6 Flavio Percoco 2014-04-29 03:20:31 EDT
Summer, the work on the nova side was postponed to Juno. That is correct. However, the multi-location support has been around in Glance since Havana. The issue is that we don't have support in the client side, yet, which means it's not really usable by the final user.

To answer your question on c#2, there's no impact from a user's perspective. The user continues to use glance just like before. Glance handles the multiple locations support transparently.

In the near future, when we'll have client support for it, the user will be able to add more locations and there will hopefully be support for it in Horizon.
Comment 7 Summer Long 2014-05-09 03:07:23 EDT
Moving to Juno, per Flavio's comment.
Comment 8 Summer Long 2014-11-24 01:06:44 EST
The dev bug has been 'Closed Deferred'.

Note You need to log in before you can comment on or make changes to this bug.