Bug 98966 - ldconfig automatically prepends /usr/lib and /lib to search order
ldconfig automatically prepends /usr/lib and /lib to search order
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-10 19:16 EDT by Jimmie Mayfield
Modified: 2016-11-24 10:19 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.2-69
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 05:49:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jimmie Mayfield 2003-07-10 19:16:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021224

Description of problem:
In RH8.0, ldconfig seems to prepend /usr/lib and /lib to the list of directories
in /etc/ld.so.conf.  This behavior differs from earlier Redhat releases and it
makes it very difficult to override libraries.

For instance, I prefer to reserve /usr/lib for "distribution binaries" and place
customized or locally-built binaries in /usr/local/lib.  Unfortunately, this new
ldconfig behavior thwarts that since it seems to always place /usr/lib and /lib
at the top of the search path.

I've tried explicitly specifying /usr/lib and /lib in /etc/ld.so.conf to no
avail.  ldconfig complains that they've been specified twice (once in the
ld.so.conf and presumably once hard-coded in the ldconfig binary).

Making users explicitly set LD_LIBRARY_PATH is messy and, in fact, won't work in
the case of SUID binaries.  So it seems with RH8.0, the only way to override the
libraries in /usr/lib or /lib is to physically replace them. :(



Version-Release number of selected component (if applicable):
glibc-2.3.2-4.80.6

How reproducible:
Always

Steps to Reproduce:
1. ldconfig -v
2. 
3.
    

Actual Results:  note that /lib and /usr/lib appear ahead of anything listed in
/etc/ld.so.conf

Expected Results:  I would have expected those directories explicitly listed in
/etc/ld.so.conf to appear ahead of any default search paths.

Additional info:
Comment 1 Jakub Jelinek 2003-10-03 05:49:54 EDT
This is fixed in glibc-2.3.2-69 and later.

Note You need to log in before you can comment on or make changes to this bug.