Bug 989691 - resource_limits.conf in prod uses different variables than in dev
resource_limits.conf in prod uses different variables than in dev
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 14:06 EDT by Rob Millner
Modified: 2015-05-14 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 14:31:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Millner 2013-07-29 14:06:46 EDT
Description of problem:
The resource_limits.conf file in prod for small gear size specifies:
max_apps=90
max_active_apps=90


Whereas the one in dev specifies:
max_active_gears=90

...and does not have a value for max_gears.


Determine which parameter is the correct one to use by inspecting the code.  

If the parameters currently used in prod have no affect, determine what the effect will be once they are set properly.

Determine what's going on with max_apps.  Should max_gears be set or is this a deprecated parameter.

Setting severity high until it can be determined whether prod has been running without enforcement of max_active_gears.
Comment 1 Thomas Wiest 2013-07-29 14:29:09 EDT
To be clear, we would prefer to use the resource_limits.conf files that the rpm ships.

I will remove the ones from puppet once the ones in the rpm have the values we need.

Thanks.
Comment 2 Rob Millner 2013-07-29 14:31:52 EDT
Yep, ran across this while I was resolving the differences between the two.  Wasn't expecting their parameters to be different.

It looks like max_apps is no longer used.  The max_active_apps parameter is silently transformed into max_active_gears inside the code.
Comment 3 openshift-github-bot 2013-07-29 16:57:55 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/984ca75591a928e086b93db31df1dafb29bd6aa4
Bug 989691 - merge values in from production.

Note You need to log in before you can comment on or make changes to this bug.