Bug 989718 - [abrt] WARNING: at kernel/time/tick-broadcast.c:640 tick_broadcast_oneshot_control+0x170/0x180()
[abrt] WARNING: at kernel/time/tick-broadcast.c:640 tick_broadcast_oneshot_co...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:f1919429247b4b4c25f8459e4ba...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 15:00 EDT by Doktorn
Modified: 2013-10-08 12:38 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 12:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (70.89 KB, text/plain)
2013-07-29 15:00 EDT, Doktorn
no flags Details

  None (edit)
Description Doktorn 2013-07-29 15:00:30 EDT
Additional info:
reporter:       libreport-2.1.5
WARNING: at kernel/time/tick-broadcast.c:640 tick_broadcast_oneshot_control+0x170/0x180()
Modules linked in: fuse ebtable_nat bnep bluetooth rfkill nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables hwmon_vid snd_hda_codec_hdmi snd_hda_codec_via snd_hda_intel snd_hda_codec acpi_cpufreq mperf kvm_amd kvm snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd soundcore joydev ppdev microcode serio_raw edac_core edac_mce_amd k10temp sp5100_tco i2c_piix4 r8169 mii parport_pc parport asus_atk0110 wmi uinput radeon ata_generic i2c_algo_bit pata_acpi drm_kms_helper ttm pata_atiixp drm i2c_core
CPU: 2 PID: 0 Comm: swapper/2 Not tainted 3.10.3-300.fc19.x86_64 #1
Hardware name: System manufacturer System Product Name/M4A785TD-V EVO, BIOS 2105    07/23/2010
 0000000000000009 ffff880129b37d68 ffffffff81643216 ffff880129b37da0
 ffffffff8105c211 0000000000000002 0000000000000004 ffff88012fc8dbc0
 0000000000000002 ffffffff81c21c40 ffff880129b37db0 ffffffff8105c2ea
Call Trace:
 [<ffffffff81643216>] dump_stack+0x19/0x1b
 [<ffffffff8105c211>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c2ea>] warn_slowpath_null+0x1a/0x20
 [<ffffffff810b3560>] tick_broadcast_oneshot_control+0x170/0x180
 [<ffffffff810b29dd>] tick_notify+0x2fd/0x440
 [<ffffffff8164d1cc>] notifier_call_chain+0x4c/0x70
 [<ffffffff81086246>] raw_notifier_call_chain+0x16/0x20
 [<ffffffff810b1f29>] clockevents_notify+0x39/0x140
 [<ffffffff81019675>] amd_e400_idle+0x75/0x100
 [<ffffffff81019e36>] arch_cpu_idle+0x26/0x30
 [<ffffffff810aa3be>] cpu_startup_entry+0xce/0x280
 [<ffffffff810b20e5>] ? clockevents_register_device+0xb5/0x120
 [<ffffffff816382ce>] start_secondary+0x24e/0x250
Comment 1 Doktorn 2013-07-29 15:00:36 EDT
Created attachment 780090 [details]
File: dmesg
Comment 2 Doktorn 2013-07-29 15:05:06 EDT
The bug is triggered by wake up from sleep. It is woken by pressing mouse button (left). It works without flaws so this error is mostly annoying.
Comment 3 igor.redhat@gmail.com 2013-07-30 20:08:44 EDT
Description of problem:
No idea; the abrtd report showed up after resuming from suspend.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.5
cmdline:        BOOT_IMAGE=/vmlinuz-3.10.3-300.fc19.x86_64 root=UUID=c07db0f8-16c8-4d06-9f59-5a04a34fb2b1 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
kernel:         3.10.3-300.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at kernel/time/tick-broadcast.c:640 tick_broadcast_oneshot_control+0x170/0x180()
Modules linked in: fuse ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack lm90 arc4 b43 bcma hp_wmi mac80211 cfg80211 sparse_keymap rfkill snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm ppdev snd_page_alloc snd_timer serio_raw snd tg3 parport_pc ptp powernow_k8 kvm_amd ssb kvm edac_core k8temp edac_mce_amd sp5100_tco i2c_piix4 hp_accel video soundcore parport wmi pps_core lis3lv02d input_polldev mmc_core shpchp uinput binfmt_misc radeon firewire_ohci i2c_algo_bit ata_generic pata_acpi firewire_core drm_kms_helper crc_itu_t ttm yenta_socket pata_atiixp drm i2c_core
CPU: 1 PID: 0 Comm: swapper/1 Not tainted 3.10.3-300.fc19.x86_64 #1
Hardware name: Hewlett-Packard HP Compaq 6715b (RK156AV)/30C2, BIOS 68YTT Ver. F.07 07/16/2007
 0000000000000009 ffff880139eafd68 ffffffff81643216 ffff880139eafda0
 ffffffff8105c211 0000000000000001 0000000000000004 ffff88013fd0dbc0
 0000000000000002 ffffffff81cb3dc0 ffff880139eafdb0 ffffffff8105c2ea
Call Trace:
 [<ffffffff81643216>] dump_stack+0x19/0x1b
 [<ffffffff8105c211>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c2ea>] warn_slowpath_null+0x1a/0x20
 [<ffffffff810b3560>] tick_broadcast_oneshot_control+0x170/0x180
 [<ffffffff810b29dd>] tick_notify+0x2fd/0x440
 [<ffffffff81018899>] ? sched_clock+0x9/0x10
 [<ffffffff8164d1cc>] notifier_call_chain+0x4c/0x70
 [<ffffffff81086246>] raw_notifier_call_chain+0x16/0x20
 [<ffffffff810b1f29>] clockevents_notify+0x39/0x140
 [<ffffffff81019675>] amd_e400_idle+0x75/0x100
 [<ffffffff81019e36>] arch_cpu_idle+0x26/0x30
 [<ffffffff810aa3be>] cpu_startup_entry+0xce/0x280
 [<ffffffff810b20e5>] ? clockevents_register_device+0xb5/0x120
 [<ffffffff816382ce>] start_secondary+0x24e/0x250
Comment 4 Tom Robbins 2013-08-14 23:08:41 EDT
Description of problem:
Showed up after boot.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.6
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.10.5-201.fc19.x86_64 root=UUID=544401ec-dd86-4f38-864c-de5e7c38ce58 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.10.5-201.fc19.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: at kernel/time/tick-broadcast.c:640 tick_broadcast_oneshot_control+0x170/0x180()
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.10.5-201.fc19.x86_64 #1
Hardware name: TOSHIBA Satellite T215D/NDU01, BIOS 1.70 03/10/2011
 0000000000000009 ffffffff81c01d78 ffffffff81638f56 ffffffff81c01db0
 ffffffff8105c211 0000000000000000 0000000000000004 ffff88023fc0dbc0
 0000000000000002 ffffffff81c21c40 ffffffff81c01dc0 ffffffff8105c2ea
Call Trace:
 [<ffffffff81638f56>] dump_stack+0x19/0x1b
 [<ffffffff8105c211>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c2ea>] warn_slowpath_null+0x1a/0x20
 [<ffffffff810b3560>] tick_broadcast_oneshot_control+0x170/0x180
 [<ffffffff810b29dd>] tick_notify+0x2fd/0x440
 [<ffffffff81642f0c>] notifier_call_chain+0x4c/0x70
 [<ffffffff81086246>] raw_notifier_call_chain+0x16/0x20
 [<ffffffff810b1f29>] clockevents_notify+0x39/0x140
 [<ffffffff81019675>] amd_e400_idle+0x75/0x100
 [<ffffffff81019e36>] arch_cpu_idle+0x26/0x30
 [<ffffffff810aa3be>] cpu_startup_entry+0xce/0x280
 [<ffffffff81623107>] rest_init+0x77/0x80
 [<ffffffff81d0aedc>] start_kernel+0x40a/0x416
 [<ffffffff81d0a8db>] ? repair_env_string+0x5c/0x5c
 [<ffffffff81d0a120>] ? early_idt_handlers+0x120/0x120
 [<ffffffff81d0a5da>] x86_64_start_reservations+0x2a/0x2c
 [<ffffffff81d0a6cf>] x86_64_start_kernel+0xf3/0x100
Comment 5 Mr. Meval 2013-08-17 18:14:42 EDT
Mine is set to only come back from suspend with keyboard and it does this.

product: M4A88TD-V EVO/USB3
vendor: ASUSTeK Computer INC.
version: Rev X.0x

Bios

vendor: American Megatrends Inc.
version: 2301
Comment 6 cooloutac 2013-08-18 10:32:18 EDT
Warning at kernel/time/tick-broadcast.c:640 tick_broadcast_oneshot_control+0x170/0x180()

I have the same exact issue.  set to resume from sleep with keyboard.  I get the same error message.  Pc runs fine other then the message.   The only thing I notice is with dmesg,  the time continues from after the time it goes to sleep and it never updates with proper time.

hwclock is correct though,  and if I hit hwclock -w and reboot or shutdown the time stays fine.   But after sleep,  the hardware time continues from when it last slept.   I don't know if this is related to this bug?  Is it a firmware bug?   I shut off UTC and use local time source, since i do dual boot with windows.  It didnt' make a diff.

This error message only started happening to me after a recent kernel update in the past week.
Comment 7 cooloutac 2013-08-18 10:34:01 EDT
just to reiterate this only happens to me on a wake from sleep.
Comment 8 hostmaster 2013-09-05 00:10:50 EDT
This happens on normal system boot also.

Vendor: American Megatrends Inc.
Version: 3029   


[    0.477587] NetLabel:  unlabeled traffic allowed by default
[    0.477629] hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0
[    0.477632] hpet0: 3 comparators, 32-bit 14.318180 MHz counter
[    0.479653] Switching to clocksource hpet
[    0.480784] ------------[ cut here ]------------
[    0.480802] WARNING: at kernel/time/tick-broadcast.c:640 tick_broadcast_oneshot_control+0x170/0x180()
[    0.480807] Modules linked in:
[    0.480815] CPU: 4 PID: 0 Comm: swapper/4 Not tainted 3.10.10-200.fc19.x86_64 #1
[    0.480820] Hardware name: System manufacturer System Product Name/M4A89GTD-PRO/USB3, BIOS 3029    07/05/2012
[    0.480824]  0000000000000009 ffff88041956dd68 ffffffff81639647 ffff88041956dda0
[    0.480834]  ffffffff8105c221 0000000000000004 0000000000000004 ffff88042fd0dbc0
[    0.480841]  0000000000000002 ffffffff81c21c40 ffff88041956ddb0 ffffffff8105c2fa
[    0.480849] Call Trace:
[    0.480862]  [<ffffffff81639647>] dump_stack+0x19/0x1b
[    0.480871]  [<ffffffff8105c221>] warn_slowpath_common+0x61/0x80
[    0.480878]  [<ffffffff8105c2fa>] warn_slowpath_null+0x1a/0x20
[    0.480885]  [<ffffffff810b3600>] tick_broadcast_oneshot_control+0x170/0x180
[    0.480894]  [<ffffffff810b2a7d>] tick_notify+0x2fd/0x440
[    0.480906]  [<ffffffff8164360c>] notifier_call_chain+0x4c/0x70
[    0.480909]  [<ffffffff810862a6>] raw_notifier_call_chain+0x16/0x20
[    0.480911]  [<ffffffff810b1fc9>] clockevents_notify+0x39/0x140
[    0.480914]  [<ffffffff81019625>] amd_e400_idle+0x75/0x100
[    0.480915]  [<ffffffff81019de6>] arch_cpu_idle+0x26/0x30
[    0.480920]  [<ffffffff810aa45e>] cpu_startup_entry+0xce/0x280
[    0.480922]  [<ffffffff810b2185>] ? clockevents_register_device+0xb5/0x120
[    0.480926]  [<ffffffff8162e6f8>] start_secondary+0x24e/0x250
[    0.480930] ---[ end trace 283ec4e00b4973f2 ]---
[    0.483810] pnp: PnP ACPI init
[    0.483820] ACPI: bus type PNP registered
Comment 9 Michael Convey 2013-09-07 16:23:18 EDT
This is 100% repeatable by resuming from sleep.
Comment 10 Alan Hamilton 2013-09-11 19:57:34 EDT
I'm also seeing it on resume. The code in tick_broadcast_oneshot_control(unsigned long reason) is

        if (reason == CLOCK_EVT_NOTIFY_BROADCAST_ENTER) {
                if (!cpumask_test_and_set_cpu(cpu, tick_broadcast_oneshot_mask)) {
                        WARN_ON_ONCE(cpumask_test_cpu(cpu, tick_broadcast_pending_mask));
                        clockevents_set_mode(dev, CLOCK_EVT_MODE_SHUTDOWN);

WARN_ON_ONCE() is a macro that ends up calling warn_slowpath_null() which prints the panic message.

It looks like the CPU is not in the expected state. I noticed that all the backtraces seem to mention amd_e400_idle(), which is for AMD cpus with the "errata 400" issue. Anyone see this with something besides an AMD? The issue is that in S1E power state, an APIC timer will not wake up the CPU.

Here's my guess: some changes were made to tick-broadcast.c (possibly this commit: https://kernel.googlesource.com/pub/scm/linux/kernel/git/stable/linux-stable/+/v3.10.3/kernel/time/tick-broadcast.c), but don't take into account the AMD S1E issue and isn't expecting some other timer to be pending (normally in S1, an APIC timer will wake the system to S0 on its own).
Comment 11 Mr. Meval 2013-09-11 21:32:23 EDT
Operating system software should enable another source of timer interrupts, such as the High Precision Event Timer, before it enters the C1 state by executing the HLT instruction and C1E is enabled using Interrupt Pending and CMP-Halt Register[C1eOnCmpHalt or SmiOnCmpHalt](MSRC001_0055[28:27] are not 00b). For purposes of determining if C1E is enabled, the operating system should not sample MSRC001_0055 until after ACPI has been enabled. Operating system software should enable another source of timer interrupts, such as the High Precision Event Timer, when the processor enters the C3 state. It is possible for the system to implement a hardware fix to C1E mode on some processor revisions and some packages. This is indicated by OSVW[1] and no workaround is necessary when
OSVW_Length >= 2 and OSVW[1] is zero.Due to erratum #669, a similar workaround may be required even when OSVW[1] = 0b. An operating system workaround for C3 mode is always necessary, regardless of the setting of OSVW[1]
Comment 12 Josh Boyer 2013-09-18 16:48:36 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 13 Alan Hamilton 2013-09-23 13:23:56 EDT
So far 3.11.1-200 does seem to resolve it. I have not had the error since upgrading, and the retrace server doesn't seem to be showing any reports for 3.11.1.
https://retrace.fedoraproject.org/faf/problems/1235713/

Note You need to log in before you can comment on or make changes to this bug.