Bug 989743 - mod_manager truncates ENABLE-APP messages
mod_manager truncates ENABLE-APP messages
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: mod_cluster (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: EAP 6.2.0
Assigned To: Jean-frederic Clere
Michal Karm Babacek
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 16:09 EDT by Aaron Ogburn
Modified: 2013-12-15 11:16 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:16:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Ogburn 2013-07-29 16:09:25 EDT
Description of problem:

mod_manager truncates ENABLE-APP messages since it reads only the first packet.  This can result in / being enabled instead of a given, more specific application context


Version-Release number of selected component (if applicable):

1.2.4.Final

How reproducible:

With test case from MODCLUSTER-349, always.  Less reproducible in actuality.

Steps to Reproduce:
1. Run MODCLUSTER-349 test case

-OR-

1. Set up jboss+mod_cluster for large ENABLE-APP messages (high alias counts) for non root context
2. Check mod_cluster-manager page to see if root was enabled instead of the expected context

Actual results:

mod_cluster doesn't read multiple packets for MCMP, potentially resulting in improper / enables.


Expected results:

mod_cluster does not enable / improperly.  It reads multi packet messages and handles them appropriately.


Additional info:

Modcluster project bug:
https://issues.jboss.org/browse/MODCLUSTER-349
Comment 1 Aaron Ogburn 2013-08-19 15:16:56 EDT
Fixed in mod_cluster per MODCLUSTER-349.  EAP 6.2.0 needs to use mod_cluster 1.2.5.Final to acquire the fix
Comment 2 Michal Karm Babacek 2013-10-01 09:07:26 EDT
Verified with EAP 6.2.ER3 / mod_cluster 1.2.6.Final.

Note You need to log in before you can comment on or make changes to this bug.