Bug 989789 - warnings about missing editors
warnings about missing editors
Status: CLOSED EOL
Product: RDO
Classification: Community
Component: python-quantumclient (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pádraig Brady
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 20:23 EDT by Derek Higgins
Modified: 2016-01-04 09:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-14 10:14:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Higgins 2013-07-29 20:23:05 EDT
Error while running packstack 

err: /Stage[main]/Openstack::Provision/Quantum_l3_ovs_bridge[br-ex]: Could not evaluate: Execution of '/usr/bin/quantum subnet-show --format=shell which: no kate in (/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin)' returned 1: which: no gedit in (/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin)
which: no kate in (/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin)
Unable to find subnet with name 'which: no kate in (/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin)'


looks like the puppet module is parsing the editor warnings as an output table

RDO on RHEL 6.4

python-cmd2-0.6.4-2.el6.noarch
python-quantum-2013.1.2-2.el6.noarch
python-quantumclient-2.2.1-2.el6.noarch
Comment 1 Martin Magr 2013-07-30 05:49:26 EDT
Workaround is to install python-cmd2-0.6.4-6 which does not emit such messages.
Comment 2 Pádraig Brady 2013-07-30 11:28:05 EDT
Martin, this build was deleted as it was never referenced:
http://koji.fedoraproject.org/koji/buildinfo?buildID=397048

I've rebuilt and submitted an update.

In general EPEL should be updated before RHOS

thanks,
Pádraig.
Comment 4 Pádraig Brady 2013-07-30 12:05:19 EDT
I've copied this build to RDO until available in Fedora19/EPEL6
Comment 6 Rich Bowen 2015-05-14 10:14:44 EDT
This refers to an end-of-lifed version that is no longer maintained. Please feel free to reopen if you feel it's still an issue.

Note You need to log in before you can comment on or make changes to this bug.