Bug 98980 - Bad: crosscompiled binary unusable
Bad: crosscompiled binary unusable
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: compat-gcc (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-11 06:07 EDT by Pertti Karppinen
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 10:32:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pertti Karppinen 2003-07-11 06:07:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Linux 2.4.20-8 i686) Opera 7.11  
[en]

Description of problem:
I get an unresolved dependency to GLIBC_2.3 when compiling a binary:
prog: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by prog)
Using nm on the non-working binary reveals only one reference to GLIBC_2.3:
 U __ctype_b_loc@@GLIBC_2.3

This seems to be related to ctype.h functions and has been reported as bug 
before, in some earlier version of Red_Hat

Version-Release number of selected component (if applicable):
compat-gcc-7.3-2.96.118

How reproducible:
Always

Steps to Reproduce:
1. create a short test.c:
#include <ctype.h>
main() {return isspace('A');}
2. i386-redhat-linux7-gcc test.c -o test
3. copy to a machine running redhat 7.2
4. Run the program
    

Actual Results:  
%./test
./test: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by ./test)
Exit 1
%

Expected Results:  nothing (the program should return 0)

Additional info:
Comment 1 Jakub Jelinek 2004-10-07 10:32:52 EDT
You are linking against RHL9 glibc, not RHL 7.2 glibc that you'd
have to use if you wanted to build programs that could run on 7.2.
glibc only has backward compatibility, not forward compatibility.

Note You need to log in before you can comment on or make changes to this bug.