Bug 989846 - Rebalance/remove-brick:Treat migration failures due to space constraints as skipped
Rebalance/remove-brick:Treat migration failures due to space constraints as s...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On:
Blocks: 990562 998077
  Show dependency treegraph
 
Reported: 2013-07-30 00:21 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 990562 998077 (view as bug list)
Environment:
Last Closed: 2014-04-17 09:13:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shishir gowda 2013-07-30 00:21:55 EDT
Description of problem:
Currently when files are ignored/skipped for migration due to space constraints (destination does not have enough space or migration leads to imbalance in cluster), we treat them as failures too. These files are shown as failures in the cli output(status)

We need to separate these out, and treat them correctly as ignored/skipped to prevent users from getting worried with the failure counts.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-07-30 00:27:59 EDT
REVIEW: http://review.gluster.org/5399 (cluster/dht: Treat migration failures due to space constraints as skipped) posted (#3) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-07-30 23:52:49 EDT
REVIEW: http://review.gluster.org/5399 (cluster/dht: Treat migration failures due to space constraints as skipped) posted (#4) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 3 Anand Avati 2013-07-31 02:56:38 EDT
COMMIT: http://review.gluster.org/5399 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit e306698b00d2d3e736cbc97a1383bfb5d3724796
Author: shishir gowda <sgowda@redhat.com>
Date:   Fri Jul 26 11:59:12 2013 +0530

    cluster/dht: Treat migration failures due to space constraints as skipped
    
    Currently rebalance/remove-brick op's display migration failed count even
    for files which failed due to space issues (not enough space for file, or
    migration leading to cluster imbalance)
    
    These will now be counted as skipped, and rebalance/remove-brick status
    will display the additional counter
    
    Change-Id: I674904d380b5f8300e9ca9e6af557c3d30d6cff4
    BUG: 989846
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5399
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 4 Anand Avati 2013-07-31 09:44:34 EDT
REVIEW: http://review.gluster.org/5446 (cluster/dht: Re-initialize skipped file count in glusterd) posted (#1) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 5 Anand Avati 2013-07-31 16:27:52 EDT
COMMIT: http://review.gluster.org/5446 committed in master by Anand Avati (avati@redhat.com) 
------
commit 691b973704b4ba511b295ee6f8baf1c4a1d8d89c
Author: shishir gowda <sgowda@redhat.com>
Date:   Wed Jul 31 19:09:52 2013 +0530

    cluster/dht: Re-initialize skipped file count in glusterd
    
    Change-Id: I42d08b3a6a7a3839f5e9953e1f83959222c080f8
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    BUG: 989846
    Reviewed-on: http://review.gluster.org/5446
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Anand Avati 2013-08-16 19:34:53 EDT
REVIEW: http://review.gluster.org/5642 (dht: Print decoded errno's along with failures during rebalance) posted (#1) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 7 Anand Avati 2013-09-20 01:53:42 EDT
REVIEW: http://review.gluster.org/5977 (cluster/dht: Treat migration failures due to space constraints as skipped) posted (#1) for review on release-3.4 by Shishir Gowda (sgowda@redhat.com)
Comment 8 Anand Avati 2013-09-20 02:40:25 EDT
COMMIT: http://review.gluster.org/5977 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 04163fc4ba5c66099c0d0c764c146f2f15f40cda
Author: shishir gowda <sgowda@redhat.com>
Date:   Fri Sep 20 11:10:09 2013 +0530

    cluster/dht: Treat migration failures due to space constraints as skipped
    
    Currently rebalance/remove-brick op's display migration failed count even
    for files which failed due to space issues (not enough space for file, or
    migration leading to cluster imbalance)
    
    These will now be counted as skipped, and rebalance/remove-brick status
    will display the additional counter
    
    BUG: 989846
    Change-Id: I4efa7ce69dd43680ff47181afed0c561954c5080
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5977
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 11 Niels de Vos 2014-04-17 09:13:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.