Bug 989867 - syslinux-tftpboot uses old /tftpboot directory
syslinux-tftpboot uses old /tftpboot directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: syslinux (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks: 1056248
  Show dependency treegraph
 
Reported: 2013-07-30 01:45 EDT by John Newbigin
Modified: 2014-10-14 02:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: syslinux-4.04-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:36:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Newbigin 2013-07-30 01:45:35 EDT
Description of problem:
syslinux-tftpboot installs files into /tftpboot but tftp-server creates and configures /var/lib/tftpboot

Version-Release number of selected component (if applicable):
syslinux-tftpboot-4.02-8.el6.x86_64
tftp-server-0.49-7.el6.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. yum install tftp-server syslinux-tftpboot
2. chkconfig tftp on
3. tftp localhost -c get pxelinux.0

Actual results:
Error code 1: File not found


Expected results:
(success)

Additional info:
I can't find any specific answers in the LSB or FHS but it seems that /var/lib/tftpboot has been adopted as the correct place for tftp files.

I don't know what selinux might permit.

see also #785955 #821481 #920744
Comment 3 Jan Stodola 2014-09-03 08:18:40 EDT
Reproduced with syslinux-tftpboot-4.02-8.el6, retested with syslinux-tftpboot-4.04-3.el6.

All files from syslinux-tftpboot are stored in /var/lib/tftpboot/, and getting pxelinux.0 from tftp works fine with default configuration.

Moving to VERIFIED.
Comment 4 Doug Mitchell 2014-09-26 01:23:32 EDT
Does this bug need to be cloned for RHEL 7?
Comment 5 errata-xmlrpc 2014-10-14 02:36:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1461.html

Note You need to log in before you can comment on or make changes to this bug.