Bug 989912 - remote-viewer on rhel6 cant make sound
remote-viewer on rhel6 cant make sound
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 03:19 EDT by mazhang
Modified: 2016-09-20 00:39 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-21 06:14:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug info of remote-viewer (134.08 KB, text/plain)
2013-07-30 03:19 EDT, mazhang
no flags Details

  None (edit)
Description mazhang 2013-07-30 03:19:25 EDT
Created attachment 780382 [details]
debug info of remote-viewer

Description of problem:
remote-viewer cant make sound,on the same machine spice client works well.

Version-Release number of selected component (if applicable):
host:
RHEL6.5-20130721.n.0
qemu-kvm-0.12.1.2-2.382.el6.x86_64
virt-viewer-0.5.6-5.el6.x86_64
spice-client-0.8.2-15.el6.x86_64

guest:
win7-32

How reproducible:
100%

Steps to Reproduce:
1.boot up win7 guest
#/usr/libexec/qemu-kvm \
-M pc \
-cpu SandyBridge \
-m 2G \
-smp 2,sockets=1,cores=2,threads=1,maxcpus=16 \
-enable-kvm \
-name win7-32 \
-uuid 990ea161-6b67-47b2-b803-19fb01d30d12 \
-smbios type=1,manufacturer='Red Hat',product='RHEV Hypervisor',version=el6,serial=koTUXQrb,uuid=feebc8fd-f8b0-4e75-abc3-e63fcdb67170 \
-k en-us \
-rtc base=localtime,clock=host,driftfix=slew \
-nodefaults \
-monitor stdio \
-qmp tcp:0:6666,server,nowait \
-boot menu=on \
-bios /usr/share/seabios/bios.bin \
-global PIIX4_PM.disable_s3=0 \
-global PIIX4_PM.disable_s4=0 \
-monitor unix:/tmp/monitor-unix,nowait,server \
-drive file=/home/win7-32.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop,aio=threads \
-device virtio-blk-pci,scsi=off,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0 \
-vga qxl \
-spice port=5900,disable-ticketing \
-device virtio-serial-pci,id=virtio-serial1 \
-chardev spicevmc,id=charchannel0,name=vdagent \
-device virtserialport,bus=virtio-serial1.0,nr=3,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 \
-netdev tap,id=hostnet0,downscript=no,vhost=on \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:2e:28:1c \
-device intel-hda,id=sound0,bus=pci.0 \
-device hda-duplex \

2. connect guest use remote-viewer and play a song.

Actual results:
remote-viewer cant make sound , but cant hist this problem while use spice client on the same machine.

Expected results:
remote-viewer can make sound

Additional info:
also try connect guest on fedora17 with virt-viewer-0.5.3-1.fc17.x86_64 and spice-client-0.10.1-5.fc17.x86_64, both of them works well ,can hear sound.
Comment 2 RHEL Product and Program Management 2013-10-13 22:54:31 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Marc-Andre Lureau 2014-02-18 13:47:11 EST
I can't reproduce. Can you still reproduce playback issues? Have you verified your sound preferences? Is the virt-viewer stream showing up there? Do you have multiple sound cards? Perhaps the dump of 'pactl list' while playing could help us?
thanks
Comment 4 mazhang 2014-02-21 03:28:28 EST
Retest this bug, problem has gone.

Host:
qemu-kvm-tools-0.12.1.2-2.415.el6_5.3.x86_64
qemu-kvm-0.12.1.2-2.415.el6_5.3.x86_64
gpxe-roms-qemu-0.9.7-6.10.el6.noarch
qemu-img-0.12.1.2-2.415.el6_5.3.x86_64
qemu-kvm-debuginfo-0.12.1.2-2.415.el6_5.3.x86_64

Guest:
win7-64

Client:
virt-viewer-0.5.6-8.el6.x86_64

Cli:
-drive file=/home/win7-64.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop,aio=threads \
-device virtio-blk-pci,scsi=off,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 \
-device intel-hda,id=sound0,bus=pci.0 \
-device hda-duplex \

Note You need to log in before you can comment on or make changes to this bug.