Bug 989915 - openstack: neutron: configuration fails: TypeError: execv() arg 2 must contain only strings
openstack: neutron: configuration fails: TypeError: execv() arg 2 must contai...
Status: CLOSED ERRATA
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.OpenStack (Show other bugs)
master
x86_64 Linux
high Severity urgent (vote)
: ---
: 1.2.0
Assigned To: Alon Bar-Lev
Meni Yakove
network
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 03:24 EDT by Meni Yakove
Modified: 2016-02-10 14:56 EST (History)
12 users (show)

See Also:
Fixed In Version: is8
Doc Type: Bug Fix
Doc Text:
Adding a host with a Neutron external network provider failed with the error: "from host_deploy log". This was caused by the engine sending integers instead of strings for configuration. These integers are now converted to strings, so adding a host with Neutron succeeds.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 10:57:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: blocker+
masayag: devel_ack+


Attachments (Terms of Use)
host-deploy and engine logs (285.25 KB, application/zip)
2013-07-30 03:24 EDT, Meni Yakove
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17457 None None None Never
Red Hat Product Errata RHBA-2014:0074 normal SHIPPED_LIVE ovirt-host-deploy bug fix and enhancement update 2014-01-21 15:15:57 EST

  None (edit)
Description Meni Yakove 2013-07-30 03:24:15 EDT
Created attachment 780383 [details]
host-deploy and engine logs

Description of problem:
Add host with neutron external provider fails with error:
from host_deploy log:

2013-07-29 17:05:32 DEBUG otopi.plugins.ovirt_host_deploy.openstack.neutron plugin.executeRaw:366 execute: ('/usr/bin/openstack-config', '--set', '/etc/quantum
/quantum.conf', 'DEFAULT', 'qpid_port', 5672), executable='None', cwd='None', env=None
2013-07-29 17:05:32 DEBUG otopi.plugins.ovirt_host_deploy.openstack.neutron plugin.executeRaw:389 execute-result: ('/usr/bin/openstack-config', '--set', '/etc/
quantum/quantum.conf', 'DEFAULT', 'qpid_port', 5672), exception
Traceback (most recent call last):
  File "/tmp/ovirt-FDNB8sGwze/pythonlib/otopi/plugin.py", line 376, in executeRaw
    env=env,
  File "/usr/lib64/python2.6/subprocess.py", line 642, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1234, in _execute_child
    raise child_exception
TypeError: execv() arg 2 must contain only strings
2013-07-29 17:05:32 DEBUG otopi.context context._executeMethod:132 method exception
Traceback (most recent call last):
  File "/tmp/ovirt-FDNB8sGwze/pythonlib/otopi/context.py", line 122, in _executeMethod
    method['method']()
  File "/tmp/ovirt-FDNB8sGwze/otopi-plugins/ovirt-host-deploy/openstack/neutron.py", line 114, in _misc
    value,
  File "/tmp/ovirt-FDNB8sGwze/pythonlib/otopi/plugin.py", line 432, in execute
    **kwargs
  File "/tmp/ovirt-FDNB8sGwze/pythonlib/otopi/plugin.py", line 376, in executeRaw
    env=env,
  File "/usr/lib64/python2.6/subprocess.py", line 642, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1234, in _execute_child
    raise child_exception
TypeError: execv() arg 2 must contain only strings

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.11.master.el6ev.noarch


Steps to Reproduce:
1.add host to cluster with neutron external provider

Actual results:
add host to cluster fails

Expected results:
successfully add host to cluster

Additional info:
Comment 1 Alon Bar-Lev 2013-07-30 03:38:12 EDT
This could have been found with simply sanity....

---

openstack: neutron: convert keys to strings


engine sends integers instead of strings for configuration, make sure
these are converted to strings.

Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=989915
Change-Id: I8dc4d250f9d143d5b56af74a7df680970b4cf107
Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>
Comment 2 Alon Bar-Lev 2013-07-30 03:39:44 EDT
Meni,

Thanks!

To progress, you can manually perform these[1] simple changes after installing ovirt-host-deploy.

Please report if it works for you.

[1] http://gerrit.ovirt.org/#/c/17457/
Comment 5 Meni Yakove 2013-08-04 02:59:23 EDT
rhevm-3.3.0-0.13.master.el6ev.noarch
Comment 6 errata-xmlrpc 2014-01-21 10:57:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0074.html

Note You need to log in before you can comment on or make changes to this bug.