Bug 989927 - Stored entries are deleted from table in rebalance
Stored entries are deleted from table in rebalance
Status: VERIFIED
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: 6.2.0
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks: 1017190
  Show dependency treegraph
 
Reported: 2013-07-30 03:41 EDT by ksuzumur
Modified: 2014-11-30 16:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1044864 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-3613 Major Resolved Stored entries are deleted from table in rebalance 2018-02-23 04:16 EST

  None (edit)
Description ksuzumur 2013-07-30 03:41:19 EDT
Created attachment 780385 [details]
Reproduce setting : clustered.xml

Description of problem:
When passivation value is false, stored entries are deleted from table in rebalance.

clustered.xml
------------
<distributed-cache name="myCache" mode="SYNC" start="EAGER">
<locking isolation="READ_COMMITTED" acquire-timeout="30000" concurrency-level="1000" striping="false"/>
<transaction mode="NONE"/>
<eviction strategy="LIRS" max-entries="10000"/>
<string-keyed-jdbc-store datasource="java:jboss/datasources/InfinispanDS" passivation="false" preload="true" purge="false" shared="true" fetch-state="false">                
...

Version-Release number of selected component (if applicable):
JDG 6.1

How reproducible:
I will attache the clustered.xml and trace logs.

Steps to Reproduce:
1.start node1 
2.put 300 entries 
3.start node2
  check entries:
  select count(*) from table;
  300
4.start node3
  check entries:
  select count(*) from table;
  0

Actual results:
In step 4, number of entries are 0 in DB table.

Expected results:
In step 4, number of entries are 300 in DB table.


Additional info:
Comment 3 JBoss JIRA Server 2013-10-09 12:15:14 EDT
William Burns <wburns@redhat.com> updated the status of jira ISPN-3613 to Coding In Progress
Comment 4 JBoss JIRA Server 2013-10-09 21:55:59 EDT
William Burns <wburns@redhat.com> made a comment on jira ISPN-3613

I am unable to reproduce this with the latest code base.  Digging further it appears this was fixed by ISPN-2903.

Side note: the xml file provided is not accurate as the log shows L1 was enabled for the cache, but the xml didn't have it enabled.

But it looks like this is caused because eviction was enabled and a rehash causes old values to be evicted.  When it was evicted it would notify the cache loader that it was removed with ISPN-2903 and would then remove it from the store as well.

I will add a test that confirms this.

Also I need to verify if when sharing is disabled if it properly evicts the entries from the cache store.
Comment 5 JBoss JIRA Server 2013-10-09 21:56:29 EDT
William Burns <wburns@redhat.com> made a comment on jira ISPN-3613

I am unable to reproduce this with the latest code base.  Digging further it appears this was fixed by ISPN-2903.

Side note: the xml file provided is not accurate as the log shows L1 was enabled for the cache, but the xml didn't have it enabled.

But it looks like this is caused because eviction was enabled and a rehash causes old values to be evicted.  When it was evicted it would notify the cache loader that it was removed with ISPN-2903 and would then remove it from the store as well.

I will add a test that confirms this.

Also I need to verify if when sharing is disabled if it properly removes the entries from the cache store.
Comment 6 JBoss JIRA Server 2013-10-10 12:30:31 EDT
William Burns <wburns@redhat.com> made a comment on jira ISPN-3613

This JIRA can probably be closed as Duplicate when tests are merged in.

Note You need to log in before you can comment on or make changes to this bug.