Bug 989932 - deleting changeset containing content views causes PGError
deleting changeset containing content views causes PGError
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 03:45 EDT by Ales Dujicek
Modified: 2014-04-24 13:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-07-30 03:45:46 EDT
Description of problem:

when you create changeset and add content view to it in UI, then deletion of changeset fails:

    ERROR: update or delete on table "changesets" violates foreign key constraint "changeset_users_changeset_id_fk" on table "changeset_users" DETAIL: Key (id)=(23) is still referenced from table "changeset_users". (PGError)
    Click here for more details.

when you add content view to changeset in CLI, it works fine

Version-Release number of selected component (if applicable):
signo-katello-0.0.9-1.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.987.b81455e.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.137.fea0d84.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-glue-pulp-1.4.2-1.git.987.b81455e.el6.noarch
katello-1.4.2-1.git.987.b81455e.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-all-1.4.2-1.git.987.b81455e.el6.noarch
katello-glue-candlepin-1.4.2-1.git.987.b81455e.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-common-1.4.2-1.git.987.b81455e.el6.noarch
katello-cli-1.4.2-1.git.137.fea0d84.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. org create --name org2
2. environment create --org org2 --prior Library --name env
3. content definition create --org org2 --name def
4. content definition publish --org org2 --name def --view_name view
5. changeset create --environment env --org org2 --name chset
6. in UI add view to changeset
7. changeset delete --environment env --org org2 --name chset

Actual results:
ERROR:  update or delete on table "changesets" violates foreign key constraint "changeset_users_changeset_id_fk" on table "changeset_users"
DETAIL:  Key (id)=(25) is still referenced from table "changeset_users".
Comment 1 RHEL Product and Program Management 2013-09-17 00:21:36 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Brad Buckingham 2013-09-26 12:08:16 EDT
katello pull request: 

https://github.com/Katello/katello/pull/3044
Comment 7 Hayk Hovsepyan 2013-10-11 08:46:04 EDT
Verified on revision:
signo-0.0.22-2.el6sat.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-1.3.0-15.el6sat.noarch
katello-cli-common-1.4.3-19.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-0.8.25-1.el6sam.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-pulp-1.4.6-29.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.4.4-3.el6sat.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-12.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
katello-qpid-broker-key-pair-1.0-1.noarch
foreman-proxy-1.3.0-3.el6sat.noarch
foreman-postgresql-1.3.0-15.el6sat.noarch
katello-cli-1.4.3-19.el6sat.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-configure-foreman-proxy-1.4.5-10.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
signo-katello-0.0.22-2.el6sat.noarch
katello-glue-candlepin-1.4.6-29.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-1.4.6-29.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
katello-configure-foreman-1.4.5-10.el6sat.noarch
katello-foreman-all-1.4.6-29.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
candlepin-cert-consumer-ares.usersys.redhat.com-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-configure-1.4.5-10.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
katello-common-1.4.6-29.el6sat.noarch
katello-glue-elasticsearch-1.4.6-29.el6sat.noarch
katello-all-1.4.6-29.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
Katello-Katello-Installation-HammerCLI-1.0-7.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Comment 8 Bryan Kearney 2014-04-24 13:10:29 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 9 Bryan Kearney 2014-04-24 13:11:42 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.