Bug 989938 - ipa pwpolicy --maxlife value is not applied correctly
ipa pwpolicy --maxlife value is not applied correctly
Status: CLOSED DUPLICATE of bug 891977
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Martin Kosek
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 03:53 EDT by David Spurek
Modified: 2015-03-02 00:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-30 11:26:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Spurek 2013-07-30 03:53:06 EDT
Description of problem:

ipa pwpolicy-mod --maxlife accept values up to 2147483647. Maxlife values 999999 and 2147483647 are not applied correctly, ipa pwpolicy-show show them correctly, but user's attribute 'krbpasswordexpiration' is set only 3 months ahead. I expected that policy will be applied correctly or maxlife value will be limited for example to 10000 value.

Version-Release number of selected component (if applicable):
server-3.0.0-25.el6

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
user's attribute 'krbpasswordexpiration' is set only 3 months ahead

Expected results:
user's attribute 'krbpasswordexpiration' is set according to pwpolicy maxlife parameter

Additional info:

upstream ticket https://fedorahosted.org/freeipa/ticket/3817
Comment 1 Martin Kosek 2013-07-30 05:05:39 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3817
Comment 2 Martin Kosek 2013-07-30 11:26:59 EDT
This will be fixed in scope of Bug 891977 (you already commented there).

*** This bug has been marked as a duplicate of bug 891977 ***

Note You need to log in before you can comment on or make changes to this bug.