Bug 989940 - Headpin Nightly : Cli command displaying list of activation key failed
Headpin Nightly : Cli command displaying list of activation key failed
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity medium
: rc
: 1.3
Assigned To: Tom McKay
Tazim Kolhar
: Triaged
Depends On:
Blocks: sam13-tracker 998675
  Show dependency treegraph
 
Reported: 2013-07-30 03:55 EDT by Tazim Kolhar
Modified: 2016-04-25 20:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 998675 (view as bug list)
Environment:
Last Closed: 2013-10-01 07:15:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2013-07-30 03:55:06 EDT
Description of problem:
Cli command displaying list of activation key failed

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-certs-tools-1.4.2-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.970.aad75f0.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.137.fea0d84.el6.noarch
katello-cli-common-1.4.2-1.git.137.fea0d84.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.970.aad75f0.el6.noarch
katello-headpin-1.4.2-1.git.970.aad75f0.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-common-1.4.2-1.git.970.aad75f0.el6.noarch
katello-headpin-all-1.4.2-1.git.970.aad75f0.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-repos-1.4.2-1.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin --user-pass=***

Steps to Reproduce:
1.# headpin -u admin -p *** activation_key create --name act_key --org ACME_Corporation
Successfully created activation key [ act_key ]

2.# headpin -u admin -p **** activation_key list --org ACME_Corporation
Invalid resource type 'content_views'. Resource Types can be one of 'organizations, environments, activation_keys, system_groups, providers, users, roles, all'


3.

Actual results:
The list command fails

Expected results:
Should display list of all activation keys for a Org

Additional info:
Comment 1 Tom McKay 2013-08-06 14:10:23 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello-cli
  Commit: 9e2c3132dc7c1f4775564c0d6426c2a9dc195577
      https://github.com/Katello/katello-cli/commit/9e2c3132dc7c1f4775564c0d6426c2a9dc195577
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-08-06 (Tue, 06 Aug 2013)
Comment 2 sthirugn@redhat.com 2013-08-19 14:38:38 EDT
VERIFIED.

Version Tested:
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-cert-consumer-cloud-qe-21.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 4 errata-xmlrpc 2013-10-01 07:15:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.