Bug 990 - findutils-4.1-24.i386.rpm
findutils-4.1-24.i386.rpm
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: findutils (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-28 21:26 EST by jprosa
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-24 19:01:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jprosa 1999-01-28 21:26:18 EST
Here is the scenario:

[nobody@limowrck /]$ whoami
nobody

[nobody@limowrck /]$ ls -al /
total 49
drwxr-xr-x  24 root     root         1024 Jan 23 15:53 .
drwxr-xr-x  24 root     root         1024 Jan 23 15:53 ..
<snip>
drwxr-x---   3 root     winblows     1024 Aug 19 17:24 dos
</snip>


[nobody@limowrck /]$ /usr/bin/updatedb
find: error in /etc/mtab: /dos/dosc: Permission denied

[nobody@limowrck /]$ df
Filesystem         1024-blocks  Used Available Capacity
Mounted on
/dev/hda2             365447   41661   304910     12%   /
df: /dos/dosc: Permission denied
/dev/hda6            1088223  167720   864278     16%
/home
/dev/hda5            1088223  574930   457068     56%   /usr
/dev/hda8             497667   20008   451957      4%   /var
/dev/hda9             209960      25   199093      0%   /tmp
/dev/hda7             590862      13   560328      0%
/spare1
/dev/hda12           1088223  519823   512175     50%
/spare2
/dev/hda13            925064      13   877260      0%
/spare3

Now why should it fail just because I close up a directory?

BUG! :)

The error should be ignored and the program be able to
continue on.  The file to fix is in find/fstype.[c,c.glibc]

I'm posting a patch right now.  (Its not the prettiest, but
it works. :)



------- Email Received From  %Junkhead% <jprosa@limowrck.erols.com> 01/28/99 21:31 -------
Comment 1 Jeff Johnson 1999-03-24 19:01:59 EST
This changes the behavior of find in order to prevent an error
message from updatedb. The error message is easily dealt with
(using grep -V).

BTW updatedb has been replaced in Red Hat 6.0.

Note You need to log in before you can comment on or make changes to this bug.