Bug 990009 - [RHSC-CLI] Inconsistency in output of 'list bricks' with all_content as true
[RHSC-CLI] Inconsistency in output of 'list bricks' with all_content as true
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc-cli (Show other bugs)
2.1
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Darshan
Shruti Sampat
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 05:06 EDT by Shruti Sampat
Modified: 2015-12-17 05:31 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 05:31:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19203 None None None Never

  None (edit)
Description Shruti Sampat 2013-07-30 05:06:32 EDT
Description of problem:
----------------------------
The output of 'list bricks' command with all_content set to true, should show the memory-allocation related fields in the same order for each memory pool as the output of the following gluster-cli command -
# gluster volume status <vol-name> mem

The mount options (mnt_options) displayed on the rhsc-shell has a value missing, as compared to the output of the following gluster-cli command -
# gluster volume status <vol-name> detail

For e.g. 

The following is from the output of the gluster-cli command -

# gluster volume status <vol-name> detail

Mount Options        : rw,noatime,nodiratime,inode64,nobarrier

The following is from the output of the rhsc-shell command -

# list bricks --cluster-identifier <cluster-name> --glustervolume-identifier <vol-name> --show-all --all_content True

mnt_options                                 : rw,noatime,nodiratime,inode6
    

Version-Release number of selected component (if applicable):
Output of 'info' command -

[RHSC shell (connected)]# info                                            
backend version: 3.3                                                      
sdk version    : 2.1                                                      
cli version    : 2.1                                                      
python version : 2.6.6.final.0                                            

entry point    : https://localhost/api   

How reproducible:
Frequently

Steps to Reproduce:
1. Create a 3.1 cluster via the Console, add a server and create a distribute volume with a single brick.
2. Via the rhsc-shell, run the 'list bricks' command in the above described syntax.
3. Check the 'gluster volume status' output for the same volume via the gluster cli, as mentioned above.

Actual results:
The above described inconsistencies are seen.

Expected results:
The output at the rhsc-shell should display the fields for each mempool in the order, that the gluster-cli displays them.

The missing mount options should be displayed at the rhsc-shell.

Additional info:

This was observed for a volume in a 3.1 cluster with RHS Update_5 storage node.
Comment 2 Dustin Tsang 2013-08-06 09:45:28 EDT
I'm also observing discrepancies when comparing the output from "list bricks --cluster-identifier %s --glustervolume-identifier --show-all --all_content True" 
with "gluster volume status %s mem".

I'm finding that the MaxAlloc for glusterfs:data_t differs.
from gluster, it has the value of 191 
from cli, is shows 147

You can see the output side-by-side here: https://gist.github.com/dstywho/c1636e7f33402b72c16c
Comment 3 Darshan 2013-09-18 03:05:30 EDT
Could not reproduce the second issue :The cropping of values in mount options field.
Comment 4 Scott Haines 2013-09-23 19:35:01 EDT
Targeting for 2.1.z U2 (Corbett) release.
Comment 5 Darshan 2013-10-18 05:55:12 EDT
In cli all fields are sorted a-z, this is done for grouping similar properties in sake of easy access.This is cross-cli behaviour.

If we change the order of fields in cli it introduces dependency to restapi implementation. Cli is a generic application that can work against any version of api/sdk. Because of this property of cli fix is not available as of now.
Comment 6 Kanagaraj 2014-05-22 00:05:49 EDT
Patch is abandoned in upstream. http://gerrit.ovirt.org/19203
Comment 7 Dusmant 2015-12-17 05:31:38 EST
RHGS-C 2.1 is EOLed and we don't have any plan to fix this. 
If you think, this is an important issue to be addressed, pls. re-open it on the latest release. I will go ahead and "CLOSE" this bug.

Note You need to log in before you can comment on or make changes to this bug.