Bug 990022 - NPE: NullPointerException: Null keys are not supported! at server shutdown
NPE: NullPointerException: Null keys are not supported! at server shutdown
Status: CLOSED DEFERRED
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ---
: TBD EAP 7
Assigned To: Paul Ferraro
Jitka Kozana
Russell Dickenson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 05:22 EDT by Jitka Kozana
Modified: 2016-02-28 11:47 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-19 07:13:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker EAP7-86 Critical Verified Graceful Shutdown and Quiescing 2016-04-05 09:05 EDT

  None (edit)
Description Jitka Kozana 2013-07-30 05:22:09 EDT
At a graceful server shutdown, we are seeing the following NPE:

04:51:06,926 ERROR [org.jboss.as.ejb3] (EJB default - 8) JBAS014251: Exception while generating session id for component RemoteStatefulSBImpl with invocation id: 29101 on channel Channel ID 1c31aeb8 (inbound) of Remoting connection 411c6c59 to /10.16.90.52:52326: java.lang.NullPointerException: Null keys are not supported!
	at org.infinispan.CacheImpl.assertKeyNotNull(CacheImpl.java:197)
	at org.infinispan.CacheImpl.assertKeyValueNotNull(CacheImpl.java:202)
	at org.infinispan.CacheImpl.putInternal(CacheImpl.java:781)
	at org.infinispan.CacheImpl.put(CacheImpl.java:777)
	at org.infinispan.DecoratedCache.put(DecoratedCache.java:320)
	at org.infinispan.AbstractDelegatingCache.put(AbstractDelegatingCache.java:308)
	at org.jboss.as.clustering.ejb3.cache.backing.infinispan.InfinispanBackingCacheEntryStore$1.invoke(InfinispanBackingCacheEntryStore.java:174)
	at org.jboss.as.clustering.ejb3.cache.backing.infinispan.InfinispanBackingCacheEntryStore$1.invoke(InfinispanBackingCacheEntryStore.java:171)
	at org.jboss.as.clustering.infinispan.invoker.SimpleCacheInvoker.invoke(SimpleCacheInvoker.java:34)
	at org.jboss.as.clustering.infinispan.invoker.BatchCacheInvoker.invoke(BatchCacheInvoker.java:48)
	at org.jboss.as.clustering.infinispan.invoker.RetryingCacheInvoker.invoke(RetryingCacheInvoker.java:81)
	at org.jboss.as.clustering.ejb3.cache.backing.infinispan.InfinispanBackingCacheEntryStore.insert(InfinispanBackingCacheEntryStore.java:178)
	at org.jboss.as.ejb3.cache.impl.backing.SerializationGroupMemberContainer.insert(SerializationGroupMemberContainer.java:304)
	at org.jboss.as.ejb3.cache.impl.backing.SerializationGroupMemberContainer.insert(SerializationGroupMemberContainer.java:51)
	at org.jboss.as.ejb3.cache.impl.backing.PassivatingBackingCacheImpl.create(PassivatingBackingCacheImpl.java:122)
	at org.jboss.as.ejb3.cache.impl.GroupAwareCache.create(GroupAwareCache.java:67)
	at org.jboss.as.ejb3.cache.impl.GroupAwareCache.create(GroupAwareCache.java:41)
	at org.jboss.as.ejb3.component.stateful.StatefulSessionComponent.createSession(StatefulSessionComponent.java:239)
	at org.jboss.as.ejb3.remote.protocol.versionone.SessionOpenRequestHandler$SessionIDGeneratorTask.run(SessionOpenRequestHandler.java:146)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439) [rt.jar:1.6.0_45]
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) [rt.jar:1.6.0_45]
	at java.util.concurrent.FutureTask.run(FutureTask.java:138) [rt.jar:1.6.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_45]
	at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_45]
	at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.1.0.Final-redhat-1.jar:2.1.0.Final-redhat-1]

Cache: DIST SYNC.
Nothing to be seen in the client log (the client log is already closed at the time of this error).

After this NPE, we are seeing a few of BZ 900999.

Link to server log:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-failover-ejb-ejbremote-netDown-dist-sync/21/artifact/report/config/jboss-perf18/server.log
Comment 1 Jitka Kozana 2013-07-30 05:24:46 EDT
Forgot to add: this is EAP 6.1.1.ER3.
Comment 2 Ladislav Thon 2013-08-26 06:07:54 EDT
Still seeing this with EAP 6.1.1.ER7. Only happens in one test case:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-failover-ejb-ejbremote-netDown-dist-sync/24/
Comment 4 Paul Ferraro 2013-12-12 10:41:24 EST
We need to file an upstream bug with Infinispan.  The KeyAffinityService is returning a null key.  This should never happen.
Comment 5 Paul Ferraro 2014-02-11 07:55:07 EST
Actually, the KeyAffinityService returns a null key because the service is stopped or is stopping - so this bug is related to clean shutdown of the EJB subsystem, a feature that is not yet implemented.
Comment 6 Radoslav Husar 2014-02-11 08:11:54 EST
The RFE to implement graceful shutdown is 
https://issues.jboss.org/browse/EAP6-7
Comment 7 Scott Mumford 2014-04-22 22:23:44 EDT
Marking for exclusion from Release Notes documentation as deferred.
Comment 8 Paul Ferraro 2014-05-21 09:26:11 EDT
This bug pertains to clean shutdown which is not scheduled to be implemented in EAP 6.x - and is targeted to be addressed in 7.0.  Setting resolution to WONTFIX.
Comment 10 Carlo de Wolf 2015-03-19 07:13:39 EDT
Moved to https://issues.jboss.org/browse/EAP7-86
Comment 11 JBoss JIRA Server 2015-08-10 21:40:00 EDT
Jason Greene <jason.greene@jboss.com> updated the status of jira EAP7-86 to Resolved
Comment 12 JBoss JIRA Server 2015-08-13 08:59:36 EDT
Radim Hatlapatka <rhatlapa@redhat.com> updated the status of jira EAP7-86 to Reopened
Comment 13 JBoss JIRA Server 2015-12-09 11:23:51 EST
Jason Greene <jason.greene@jboss.com> updated the status of jira EAP7-86 to Resolved
Comment 14 JBoss JIRA Server 2015-12-16 08:13:03 EST
Radim Hatlapatka <rhatlapa@redhat.com> updated the status of jira EAP7-86 to Reopened
Comment 15 JBoss JIRA Server 2016-02-28 11:47:39 EST
Jason Greene <jason.greene@jboss.com> updated the status of jira EAP7-86 to Resolved

Note You need to log in before you can comment on or make changes to this bug.