Bug 990026 - Deleting promoted published CV via deletion changeset failed with undefined method error
Deleting promoted published CV via deletion changeset failed with undefined m...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
high Severity medium (vote)
: Unspecified
: --
Assigned To: David Davis
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 05:25 EDT by Sachin Ghai
Modified: 2014-04-24 13:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:06:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failed to delete promoted cv (92.15 KB, image/png)
2013-07-30 05:25 EDT, Sachin Ghai
no flags Details
deletion changeset applied successfully (39.32 KB, image/png)
2013-10-21 06:09 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-07-30 05:25:13 EDT
Created attachment 780477 [details]
failed to delete promoted cv

Description of problem:
Deleting promoted published cv failed with following error:

undefined method `update_cp_content' for nil:NilClass (NoMethodError)

Version-Release number of selected component (if applicable):
undefined method `update_cp_content' for nil:NilClass (NoMethodError)

How reproducible:
always

Steps to Reproduce:
1. Promote a published cv to next env
2. delete the promoted cv via deletion changeset
3.

Actual results:
undefined method `update_cp_content' for nil:NilClass (NoMethodError)

Expected results:
Deletion changeset should be applied successfully

Additional info:
Comment 1 Sachin Ghai 2013-07-30 05:28:14 EDT
Error logs from production.log:

--
[ERROR 2013-07-30 07:57:09 app  #1544] <NoMethodError> undefined method `update_cp_content' for nil:NilClass
	/usr/share/katello/app/models/deletion_changeset.rb:49:in `delete_content'
	/usr/share/katello/app/models/async_operation.rb:58:in `perform'
	/opt/rh/ruby193/root/usr/share/gems/gems/delayed_job-3.0.2/lib/delayed/backend/base.rb:94:in `block in invoke_job'
	/opt/rh/ruby193/root/usr/share/gems/gems/delayed_job-3.0.2/lib/delayed/lifecycle.rb:60:in `call'
	/opt/rh/ruby193/root/usr/share/gems/gems/delayed_job-3.0.2/lib/delayed/lifecycle.rb:60:in `block in initialize'
	/opt/rh/ruby193/root/usr/share/gems/gems/delayed_job-3.0.2/lib/delayed/lifecycle.rb:65:in `call'
	/opt/rh/ruby193/root/usr/share/gems/gems/delayed_job-3.0.2/lib/delayed/lifecycle.rb:65:in `execute'
	/opt/rh/ruby193/root/usr/share/gems/gems/delayed_job-3.0.2/lib/delayed/lifecycle.rb:38:in `run_callbacks'
	/opt/rh/ruby193/root/usr/share/gems/gems/delayed_job-3.0.2/lib/delayed/backend/base.rb:91:in `invoke_job'
	/opt/rh/ruby193/root/usr/share/gems/gems/delayed_job-3.0.2/lib/delayed/worker.rb:178:in `block (2 levels) in run'
--
Comment 2 RHEL Product and Program Management 2013-09-17 00:21:26 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Eric Helms 2013-10-08 14:39:05 EDT
I tested this on the latest and everything seemed to work OK for me. Moving to POST to be verified.
Comment 6 Sachin Ghai 2013-10-21 06:08:16 EDT
Verified with snap6 compose2 (MDP2)

katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.7-6.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch

I can delete the promoted cv from next env via deletion changeset and without reported error.
Comment 7 Sachin Ghai 2013-10-21 06:09:01 EDT
Created attachment 814511 [details]
deletion changeset applied successfully
Comment 8 Bryan Kearney 2014-04-24 13:06:54 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.