Bug 99003 - kernel panic at try_to_unmap_one
kernel panic at try_to_unmap_one
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-11 12:17 EDT by Michael Young
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 18:05:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2003-07-11 12:17:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
I have had the following kernel panic on a dual cpu 7.3 machine running squid.
The machine has been crashing every so often since I upgraded to 2.4.20-18.7smp
but this is the first time I have got a crash dump (via serial logging to
another box).

Unable to handle kernel paging request at virtual address 02bad4d7
 printing eip:
c01436ad
*pde = 00000000
Oops: 0002
nfs lockd sunrpc ip_conntrack_ftp autofs eepro100 mii ipt_LOG ipt_REJECT
ipt_state ip_conntrack iptable_filter ip_tables ext3 jbd raid1 aic7xxx sd_mod
scsi_mo
CPU:    1
EIP:    0010:[<c01436ad>]    Not tainted
EFLAGS: 00010246
 
EIP is at try_to_unmap_one [kernel] 0x14d (2.4.20-18.7smp)
eax: 00000000   ebx: 55470892   ecx: fffe3000   edx: 02bad4ab
esi: 55610892   edi: c1000030   ebp: fffe3680   esp: f7ff3f48
ds: 0018   es: 0018   ss: 0018
Process kswapd (pid: 5, stackpage=f7ff3000)
Stack: 02ffa400 02bad4ab c10106b0 c10106b0 c10106b0 00000006 c030c0a0 ffffffff
       c01437ca 02ffa400 c10106b0 c013e7f0 c03b8560 00000000 00000000 00000000
       c10106b0 c030c0a0 c030c020 c0139a04 00000001 0000002c c030c0a0 c030d258
Call Trace:   [<c01437ca>] try_to_unmap [kernel] 0x6a (0xf7ff3f68))
[<c013e7f0>] add_to_swap [kernel] 0x60 (0xf7ff3f74))
[<c0139a04>] launder_page [kernel] 0x5a4 (0xf7ff3f94))
[<c013bdfa>] rebalance_dirty_zone [kernel] 0x9a (0xf7ff3fac))
[<c013cb1f>] kswapd [kernel] 0x48f (0xf7ff3fcc))
[<c0105000>] stext [kernel] 0x0 (0xf7ff3fe8))
[<c0107266>] arch_kernel_thread [kernel] 0x26 (0xf7ff3ff0))
[<c013c690>] kswapd [kernel] 0x0 (0xf7ff3ff8))
 
 
Code: 86 42 2c 84 c0 7f 0c b8 01 00 00 00 e9 92 00 00 00 89 f6 56
Comment 1 Michael Young 2004-06-24 18:05:51 EDT
I haven't seen this bug recently so I am guessing it is either fixed,
or too infrequent to worry about.

Note You need to log in before you can comment on or make changes to this bug.