Bug 990053 - fail to disable e1000 nic in win2012 guest
fail to disable e1000 nic in win2012 guest
Status: CLOSED DUPLICATE of bug 874406
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Windows
medium Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 06:04 EDT by FuXiangChun
Modified: 2013-08-26 11:32 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 11:32:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FuXiangChun 2013-07-30 06:04:47 EDT
Description of problem:
Boot win2012 guest with e1000 nic, then try to disable it in guest.  it will cause guest hang. 

BTW, virtio and rtl8139 don't hit this issue. and win7-64 guest also don't this issue.  

Version-Release number of selected component (if applicable):
# uname -r
3.10.0-3.el7.x86_64
# rpm -qa|grep qemu-kvm
qemu-kvm-1.5.2-1.el7.x86_64

How reproducible:
8/10

Steps to Reproduce:
1. /usr/libexec/qemu-kvm -name 'virtio-network' -nodefaults -m 4G -smp 4,cores=2,threads=2,sockets=1 -M q35 -cpu Opteron_G2 -rtc base=utc,clock=host,driftfix=slew -k en-us -boot menu=on -monitor stdio -vnc :1 -spice disable-ticketing,port=5931 -qmp tcp:0:5555,server,nowait -vga qxl \

-drive file=/home/win2012-64-virtio.qcow2,if=none,id=drive-scsi-disk,format=qcow2,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,id=scsi0,drive=drive-scsi-disk -balloon virtio-balloon-pci,id=balloon \

-device virtio-net-pci,netdev=fuxc,mac=00:24:21:7f:0d:10,id=n1 -netdev tap,id=fuxc,vhost=on,script=/etc/qemu-ifup  \

-device e1000,netdev=vnet1,id=vnic1,mac=54:52:01:1a:2c:04 -netdev tap,id=vnet1,script=/etc/qemu-ifup

2. disable e1000 nic in Device Manager
3.

Actual results:
guest hang

and cpu and memory usage will rise by qemu-kvm process  
3470 root 20 0 6819972 3.977g   6328 S 102.9 54.6  35:40.64 qemu-kvm


Expected results:
disable successfully and guest work well

Additional info:
Comment 2 Andrew Jones 2013-07-30 12:16:51 EDT
Take a look at the comments in bug 874406 for some history when the last person (me) attempted to debug this.
Comment 3 Yan Vugenfirer 2013-08-26 11:32:39 EDT

*** This bug has been marked as a duplicate of bug 874406 ***

Note You need to log in before you can comment on or make changes to this bug.