Bug 990060 - Dist-geo-rep : 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> delete' command deletes all session having that slave_vol name ; even though sessions are between same master and diffident slave cluster
Dist-geo-rep : 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> delet...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Avra Sengupta
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 06:17 EDT by Rachana Patel
Modified: 2015-04-20 07:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 991501 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-30 06:17:05 EDT
Description of problem:
 Dist-geo-rep : 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> delete' command deletes all session having that slave_vol name ; even though sessions are between same master and diffident slave cluster

Version-Release number of selected component (if applicable):
always

How reproducible:
3.4.0.13rhs-1.el6rhs.x86_64

Steps to Reproduce:
1.had a 2 slave cluster; having same volume name
slave cluster 1 :-
rhsauto018
rhsauto031
rhsauto026
rhsauto027
volume name :- slave4

slave cluster 2 :-
10.70.43.147 - 
10.70.43.114
10.70.43.115
10.70.43.103
volume name :- slave4


2. create session :- one with slave cluster 1 and another with slave cluster 2
start those sessions

[root@DVM4 geo-replication]#  gluster volume geo test4 rhsauto018.lab.eng.blr.redhat.com::slave4 create
root@DVM4 geo-replication]#  gluster volume geo test4 rhsauto018.lab.eng.blr.redhat.com::slave4 create
Creating geo-replication session between test4 & rhsauto018.lab.eng.blr.redhat.com::slave4 has been successful
[root@DVM4 geo-replication]#  gluster volume geo test4 rhsauto018.lab.eng.blr.redhat.com::slave4 status
NODE                           MASTER   SLAVE                                        HEALTH         UPTIME       
-----------------------------------------------------------------------------------------------------------------
DVM5.lab.eng.blr.redhat.com    test4    rhsauto018.lab.eng.blr.redhat.com::slave4    Not Started    N/A          
DVM2.lab.eng.blr.redhat.com    test4    rhsauto018.lab.eng.blr.redhat.com::slave4    Not Started    N/A          
DVM6.lab.eng.blr.redhat.com    test4    rhsauto018.lab.eng.blr.redhat.com::slave4    Not Started    N/A          
DVM1.lab.eng.blr.redhat.com    test4    rhsauto018.lab.eng.blr.redhat.com::slave4    Not Started    N/A          
DVM3.lab.eng.blr.redhat.com    test4    rhsauto018.lab.eng.blr.redhat.com::slave4    Not Started    N/A          
[root@DVM4 geo-replication]#  gluster volume geo test4 rhsauto018.lab.eng.blr.redhat.com::slave4 start
Starting geo-replication session between test4 & rhsauto018.lab.eng.blr.redhat.com::slave4 has been successful
[root@DVM4 geo-replication]#  gluster volume geo test4 10.70.43.103::slave4 create push-pem
Creating geo-replication session between test4 & 10.70.43.103::slave4 has been successful
[root@DVM4 geo-replication]#  gluster volume geo test4 10.70.43.103::slave4 status
NODE                           MASTER   SLAVE                   HEALTH         UPTIME       
--------------------------------------------------------------------------------------------
DVM3.lab.eng.blr.redhat.com    test4    10.70.43.103::slave4    Not Started    N/A          
DVM1.lab.eng.blr.redhat.com    test4    10.70.43.103::slave4    Not Started    N/A          
DVM2.lab.eng.blr.redhat.com    test4    10.70.43.103::slave4    Not Started    N/A          
DVM5.lab.eng.blr.redhat.com    test4    10.70.43.103::slave4    Not Started    N/A          
DVM6.lab.eng.blr.redhat.com    test4    10.70.43.103::slave4    Not Started    N/A          
[root@DVM4 geo-replication]#  gluster volume geo test4 10.70.43.103::slave4 start
Starting geo-replication session between test4 & 10.70.43.103::slave4 has been successful
[root@DVM4 geo-replication]#  gluster volume geo test4 status
NODE                           MASTER   SLAVE                                              HEALTH             UPTIME       
---------------------------------------------------------------------------------------------------------------------------
DVM3.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Initializing...    N/A          
DVM3.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty             N/A          
DVM5.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Initializing...    N/A          
DVM5.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty             N/A          
DVM2.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Initializing...    N/A          
DVM2.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty             N/A          
DVM6.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Initializing...    N/A          
DVM6.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty             N/A          
DVM1.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Initializing...    N/A          
DVM1.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty             N/A         


3. stop and delete one session and verify that it has also deleted another session having same vol_name.

[root@DVM4 geo-replication]#  gluster volume geo test4 10.70.43.103::slave4 stop
Stopping geo-replication session between test4 & 10.70.43.103::slave4 has been successful
[root@DVM4 geo-replication]#  gluster volume geo test4 status
NODE                           MASTER   SLAVE                                              HEALTH     UPTIME       
-------------------------------------------------------------------------------------------------------------------
DVM5.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Stopped    N/A          
DVM5.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty     N/A          
DVM3.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Stopped    N/A          
DVM3.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty     N/A          
DVM2.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Stopped    N/A          
DVM2.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty     N/A          
DVM6.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Stopped    N/A          
DVM6.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty     N/A          
DVM1.lab.eng.blr.redhat.com    test4    ssh://10.70.43.103::slave4                         Stopped    N/A          
DVM1.lab.eng.blr.redhat.com    test4    ssh://rhsauto018.lab.eng.blr.redhat.com::slave4    faulty     N/A          
[root@DVM4 geo-replication]#  gluster volume geo test4 10.70.43.103::slave4 delete
Deleting geo-replication session between test4 & 10.70.43.103::slave4 has been successful
[root@DVM4 geo-replication]#  gluster volume geo test4 status
No active geo-replication sessions for test4


Actual results:
deleting all sessions having that slave volume name

Expected results:
It should not delete all session

Additional info:
Comment 2 Avra Sengupta 2013-08-02 11:05:57 EDT
The patch that fixes this bug, changes the path where the session info like config, and status details are stored. Hence with this, patch, when an rpm upgrade is performed, the previous session config will not be supported. New geo-rep session must be created after installing this patch.
Comment 4 Rachana Patel 2013-08-13 04:27:40 EDT
verified with 3.4.0.18rhs-1.el6rhs.x86_64 and working as per expected
(not deleting all sessions)
Comment 5 Scott Haines 2013-09-23 18:38:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:41:30 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.