Bug 990084 - Remove options that are deprecated in Big Bend (Geo-replication commands in particular)
Remove options that are deprecated in Big Bend (Geo-replication commands in p...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Venky Shankar
M S Vishwanath Bhat
:
Depends On:
Blocks: 994461
  Show dependency treegraph
 
Reported: 2013-07-30 07:05 EDT by Sachidananda Urs
Modified: 2016-05-31 21:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.18rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 994461 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:35:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2013-07-30 07:05:55 EDT
Description of problem:

This bug is a tracker bug to remove all the deprecated options.
There are a few options that are no longer relevant as the features evolved in newer versions.

For example:

config --special-sync-mode blind
config --special-sync-mode wrap-up

Please identify such options and remove them and print a proper error  message stating they are removed/do-not-exist/command-not-found
Comment 4 Vijaykumar Koppad 2013-08-14 09:05:44 EDT
Right now if you do config special-sync-mode blind, or config special-sync-mode wrap-up it doesn't say any error message like , but the geo-rep status goes to faulty. 

root@shaktiman ~]# gluster v geo master 10.70.43.23::imaster config special-sync-mode blind
geo-replication config updated successfully


But this happens with any other value,not only with blind or wrap-up

[root@shaktiman ~]# gluster v geo master 10.70.43.23::imaster config special-sync-mode sDGs
geo-replication config updated successfully


and the log file will have the backtraces like 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[2013-08-14 18:11:17.13478] I [master(/bricks/brick1):57:gmaster_builder] <top>: setting up xsync change detection mode
[2013-08-14 18:11:17.14095] E [syncdutils(/bricks/brick1):206:log_raise_exception] <top>: FAIL:
Traceback (most recent call last):
  File "/usr/libexec/glusterfs/python/syncdaemon/gsyncd.py", line 133, in main
    main_i()
  File "/usr/libexec/glusterfs/python/syncdaemon/gsyncd.py", line 513, in main_i
    local.service_loop(*[r for r in [remote] if r])
  File "/usr/libexec/glusterfs/python/syncdaemon/resource.py", line 1047, in service_loop
    (g1, g2) = self.gmaster_instantiate_tuple(slave)
  File "/usr/libexec/glusterfs/python/syncdaemon/resource.py", line 1015, in gmaster_instantiate_tuple
    return (gmaster_builder('xsync')(self, slave), gmaster_builder()(self, slave))
  File "/usr/libexec/glusterfs/python/syncdaemon/master.py", line 58, in gmaster_builder
    modemixin = getattr(this, modemixin.capitalize() + 'Mixin')
AttributeError: 'module' object has no attribute 'SdgsMixin'

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>


This doesn't have any problem of data corruption or something.
Since this is a different issue, it is being tracked with this Bug 996999,
and making it verified on glusterfs-3.4.0.20rhs-1.el6rhs.x86_64
Comment 5 Scott Haines 2013-09-23 18:35:56 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.