Bug 990094 - No tabs in Process Definitions / Instances
No tabs in Process Definitions / Instances
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER2
: 6.0.0
Assigned To: Mauricio Salatino
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 07:19 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-07-30 07:19:31 EDT
Description of problem:
There used to be separate tabs for the list of process definitions/instances and the details of each of those definitions/instances. Now there are no tabs, screen with the list of definitions/instances is replaced by the screen with the view of details when you click the details button.

This makes for a much worse user experience. Without tabs, users can't configure the layout (they should be allowed to do that).


Version-Release number of selected component (if applicable):
kie-wb CR1


Additional information:
Consider this scenario: There is a process XY, with multiple instances running. One of them was started by mistake or with bad data. The user won't be able to tell which one until he/she looks into the instance details. There, the instance ID can be found as well, but won't help one bit, since the list of instances doesn't display instance IDs. In the details, there also isn't any button to abort the instance or do anything like that to it. So, the user has to look up in the instance log the start time of this instance, write it down somewhere, again go to process instances and search for an instance with that start time.
Tabs make this at least a bit easier, since you can have multiple detail tabs open at the same time - third instance in the list can correspond to third details tab. Whatever you want to do with the details, with tabs, you can have a better idea what you are looking at, you can compare by putting two detail tabs next to each other etc.
Comment 1 Mauricio Salatino 2013-08-02 11:12:37 EDT
Fixed in master: https://github.com/droolsjbpm/jbpm-console-ng/commit/f160318b38708f376e21235ab5ffd0ecf9601cc1

The old tabs were replaced by the list stacks provided by UF 0.3

Note You need to log in before you can comment on or make changes to this bug.