Bug 99011 - Full backup of root directory using 'tar' causes system reboot
Summary: Full backup of root directory using 'tar' causes system reboot
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: tar   
(Show other bugs)
Version: 2.1
Hardware: ia64 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-11 17:36 UTC by dnd
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-11 20:37:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dnd 2003-07-11 17:36:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (WinNT; U)

Description of problem:
ia64/IPF (rx2600) system reboots during execution of "tar cvf fullbackup.tar /" command. The culprit is /proc filesystem. If the tar 
command excludes the /proc filesystem, the tar command is successful without a system reboot. 

It turns out the the problem is the ia-64 memory space with its embedded I/O memory and holes.  If you read one of these invalid 
memory locations you will MCA.  For example, just wc /proc/kcore you will generate an MCA and reboot. 




Version-Release number of selected component (if applicable):
tar-1.13.25-4.AS21.0

How reproducible:
Always

Steps to Reproduce:
1. Execute "tar cvf fullbackup.tar /" 
2. System would reboot during the backup of /proc filesystem.
3.
    

Actual Results:  Automatic System Reboot

Expected Results:  System should NOT automatically reboot during backup of /proc filesystem.

Additional info

Comment 1 dnd 2003-07-11 17:41:51 UTC
[root@netuxipf root]# cat /etc/redhat-release
Red Hat Linux Advanced Server release 2.1AS (Derry)

[root@netuxipf root]# uname -a
Linux netuxipf 2.4.18-e.31smp #1 SMP Wed May 21 17:47:59 EDT 
2003 ia64 unknown


Comment 2 Bill Nottingham 2003-07-11 20:37:06 UTC
Reading of memory holes and other I/O space is expected to MCA.


Note You need to log in before you can comment on or make changes to this bug.