Bug 990112 - IIOPNamingTestCase is failing when run on IBM JDK
IIOPNamingTestCase is failing when run on IBM JDK
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: EAP 6.2.0
Assigned To: Ondřej Žižka
Pavel Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 08:13 EDT by Ondrej Chaloupka
Modified: 2013-12-15 11:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:22:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1783 Major Resolved IIOPNamingTestCase is failing when run on IBM JDK 2014-07-16 07:46:53 EDT

  None (edit)
Description Ondrej Chaloupka 2013-07-30 08:13:41 EDT
Testcase org.jboss.as.test.integration.ejb.iiop.naming.IIOPNamingTestCase is failing when is run on IBM JDK with message
Unable to load class: org.jboss.as.test.integration.ejb.iiop.naming._IIOPNamingHome_Stub

The stack trace:

java.lang.ClassCastException: Unable to load class: org.jboss.as.test.integration.ejb.iiop.naming._IIOPNamingHome_Stub
 at com.ibm.rmi.javax.rmi.PortableRemoteObject.narrow(PortableRemoteObject.java:356)
 at javax.rmi.PortableRemoteObject.narrow(PortableRemoteObject.java:148)
 at org.jboss.as.test.integration.ejb.iiop.naming.IIOPNamingTestCase.testIIOPNamingInvocation(IIOPNamingTestCase.java:65)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
 at java.lang.reflect.Method.invoke(Method.java:611)
 at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
 at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
 at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
 at org.jboss.arquillian.junit.Arquillian$6$1.invoke(Arquillian.java:270)
 at org.jboss.arquillian.container.test.impl.execution.LocalTestExecuter.execute(LocalTestExecuter.java:60)
 at sun.reflect.GeneratedMethodAccessor43.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
 at java.lang.reflect.Method.invoke(Method.java:611)
...


The reason seem to be that the stubs are not generated. As I found there is no option to force jdk generate stubs on the fly (oracle jdk knows -Dcom.sun.CORBA.ORBUseDynamicStub=true) and the generation of stubs have to be done manually e.g. with rmic tool.
Comment 1 JBoss JIRA Server 2013-08-01 07:02:32 EDT
Ondřej Chaloupka <ochaloup@redhat.com> updated the status of jira WFLY-1783 to Resolved
Comment 2 JBoss JIRA Server 2013-08-01 07:02:32 EDT
Ondřej Chaloupka <ochaloup@redhat.com> made a comment on jira WFLY-1783

The pom.xml change for basic module of testsuite was merged.
Comment 4 Ondrej Chaloupka 2013-09-18 05:17:36 EDT
Verified on 6.2.0.ER1.
The ibm jdk test fix is in.

Note You need to log in before you can comment on or make changes to this bug.