Bug 990162 - [abrt] astyle-2.02.1-4.fc19: astyle::ASFormatter::nextLine: Process /usr/bin/astyle was killed by signal 6 (SIGABRT)
[abrt] astyle-2.02.1-4.fc19: astyle::ASFormatter::nextLine: Process /usr/bin/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: astyle (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
abrt_hash:f2ea92980483b2ab8c8f733409f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 09:51 EDT by Michael Jordan
Modified: 2013-08-12 04:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: astyle-2.03-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 23:55:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (26.58 KB, text/plain)
2013-07-30 09:51 EDT, Michael Jordan
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-30 09:51 EDT, Michael Jordan
no flags Details
File: core_backtrace (978 bytes, text/plain)
2013-07-30 09:51 EDT, Michael Jordan
no flags Details
File: dso_list (580 bytes, text/plain)
2013-07-30 09:51 EDT, Michael Jordan
no flags Details
File: environ (4.85 KB, text/plain)
2013-07-30 09:51 EDT, Michael Jordan
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-30 09:51 EDT, Michael Jordan
no flags Details
File: maps (2.97 KB, text/plain)
2013-07-30 09:51 EDT, Michael Jordan
no flags Details
File: open_fds (105 bytes, text/plain)
2013-07-30 09:51 EDT, Michael Jordan
no flags Details
File: proc_pid_status (977 bytes, text/plain)
2013-07-30 09:51 EDT, Michael Jordan
no flags Details

  None (edit)
Description Michael Jordan 2013-07-30 09:51:18 EDT
Description of problem:
trying to run astyle on the 3.10 kernel source files

Version-Release number of selected component:
astyle-2.02.1-4.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        astyle -r *.c *.h
crash_function: astyle::ASFormatter::nextLine
executable:     /usr/bin/astyle
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000
var_log_messages: Jul 30 09:25:50 mach1 abrt[2248]: Saved core dump of pid 2246 (/usr/bin/astyle) to /var/tmp/abrt/ccpp-2013-07-30-09:25:50-2246 (3788800 bytes)

Truncated backtrace:
Thread no. 1 (3 frames)
 #4 astyle::ASFormatter::nextLine at src/ASFormatter.cpp:719
 #5 astyle::ASConsole::formatFile at src/astyle_main.cpp:501
 #6 astyle::ASConsole::processFiles at src/astyle_main.cpp:1666
Comment 1 Michael Jordan 2013-07-30 09:51:24 EDT
Created attachment 780673 [details]
File: backtrace
Comment 2 Michael Jordan 2013-07-30 09:51:31 EDT
Created attachment 780674 [details]
File: cgroup
Comment 3 Michael Jordan 2013-07-30 09:51:34 EDT
Created attachment 780675 [details]
File: core_backtrace
Comment 4 Michael Jordan 2013-07-30 09:51:39 EDT
Created attachment 780676 [details]
File: dso_list
Comment 5 Michael Jordan 2013-07-30 09:51:42 EDT
Created attachment 780677 [details]
File: environ
Comment 6 Michael Jordan 2013-07-30 09:51:44 EDT
Created attachment 780678 [details]
File: limits
Comment 7 Michael Jordan 2013-07-30 09:51:47 EDT
Created attachment 780679 [details]
File: maps
Comment 8 Michael Jordan 2013-07-30 09:51:51 EDT
Created attachment 780680 [details]
File: open_fds
Comment 9 Michael Jordan 2013-07-30 09:51:55 EDT
Created attachment 780681 [details]
File: proc_pid_status
Comment 10 Fedora Update System 2013-07-30 10:21:16 EDT
astyle-2.03-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/astyle-2.03-1.fc19
Comment 11 Fedora Update System 2013-08-01 23:37:14 EDT
Package astyle-2.03-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing astyle-2.03-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13982/astyle-2.03-1.fc19
then log in and leave karma (feedback).
Comment 12 Michael Jordan 2013-08-05 19:15:11 EDT
No, I have downloaded the recommended package.  The result is:

astyle: src/ASFormatter.cpp:5871: bool astyle::ASFormatter::isArrayOperator() const: Assertion `currentChar == '*' || currentChar == '&'' failed.

I note also that when I run astyle -h two of the options now have the same short operator -xd. To eliminate any doubt I put delete-empty-lines in my ~/.astylerc. The result is as above, though.
Comment 13 Thomas Spura 2013-08-06 04:28:43 EDT
I could reproduce this issue with the old version and it is gone with the update.
The file seems to be:
arch/xtensa/kernel/platform.c

Could you maybe move your .astylerc out of the way and try it again? Maybe it is some flag that raises this issue again?

Could you maybe point me to a file/flags that reproduce this issue for you?
Comment 14 Michael Jordan 2013-08-06 18:18:51 EDT
Okay, I am doing this on the 3.10 kernel source. I execute astyle -r *.c *.h

It makes it through quite a bit, but it does seem to die on drivers/scsi/ncr53c8xx.c

I tried astyle "drivers/scsi/ncr53c8xx.c" and it does produce the error shown.

Also tried the following:

[root@mach2 linux-3.10]# mv ~/.astylerc ~/astyle.bak
[root@mach2 linux-3.10]# astyle "drivers/scsi/ncr53c8xx.c"
astyle: src/ASFormatter.cpp:5871: bool astyle::ASFormatter::isArrayOperator() const: Assertion `currentChar == '*' || currentChar == '&'' failed.
Aborted
[root@mach2 linux-3.10]#

I've found 3 files that crash it:

drivers/scsi/ncr53c8xx.c
drivers/scsi/sym53c8xx_2/sym_fw1.h
drivers/scsi/sym53c8xx_2/sym_fw2.h
Comment 15 Fedora Update System 2013-08-09 23:55:39 EDT
astyle-2.03-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Michael Jordan 2013-08-10 00:15:42 EDT
I guess I forgot to mention that my Comment 14 was *after* I had downloaded astyle 2.03-1.fc19. So the problem is still there, specifically with the 3 files that I mentioned.
Comment 17 Fedora Update System 2013-08-10 08:34:51 EDT
astyle-2.03-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Thomas Spura 2013-08-12 04:14:23 EDT
As the initial bug from comment #0 is gone, I'll leave this bug closed.

Your next issue will be tracked in bug #996008.
I can reproduce your issue with this file:
https://raw.github.com/genesi/linux-legacy/master/drivers/scsi/ncr53c8xx.c

Note You need to log in before you can comment on or make changes to this bug.