Bug 990192 - EAP6-javadoc Jenkins job generates wrong branding title
EAP6-javadoc Jenkins job generates wrong branding title
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Build (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ER6
: EAP 6.1.1
Assigned To: Yong Yang
Petr Kremensky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 10:35 EDT by Vladimir Dosoudil
Modified: 2015-02-20 06:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:25:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Dosoudil 2013-07-30 10:35:54 EDT
The Jenkins job for generating Javadoc for EAP 6 [1] generates title

"JBoss Enterprise Application Platform $JBOSS_EAP_VERSION"; public API

instead of using the proper evaluation of $JBOSS_EAP_VERSION and correct notation without inappropriate characters such as quotation mark and semicolon. The correct one looks like this:

JBoss Enterprise Application Platform 6.1.1.GA public API

See build #35 and #37 of the job [1] for the reference of this issue.

The process described in javadoc/README.TXT (in jboss-as) works correctly if you choose "manual way" i.e. building javadoc out of the Jenkins job.

[1] https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/EAP6-javadoc
Comment 1 Paul Gier 2013-08-14 14:37:24 EDT
This issue was fixed in ER5 with a change to the Jenkins config.  Marking it for ER6 to get the required Acks.
Comment 2 Pavel Jelinek 2013-08-21 10:10:32 EDT
Runs of the Jenkins job from #45 (EAP 6.1.1.ER5) onward are ok from this PoV.

Note You need to log in before you can comment on or make changes to this bug.