Bug 9902 - Red Hat 6.1 Adaptec aic7xxxx driver hangs with SCSI Ultra3 drive
Summary: Red Hat 6.1 Adaptec aic7xxxx driver hangs with SCSI Ultra3 drive
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-01 19:45 UTC by bbetanco
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 17:42:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bbetanco 2000-03-01 19:45:10 UTC
Our mutual customer is in the process of qualifying the IBM Ultrastar 36LP
Hard Drive on the Intel L440GXC Server Motherboard.  It is their first SCSI
U160 drive qualification.
System configuration:
Intel  L440GXC motherboard w/ onboard Adaptec AIC-7896 SCSI Controller
w/BIOS v2.20S1B1.
OS Redhat Linux 6.1
Pisces - 36GB - 80pin w/ S60B

Bottom line.. During Linux installation from CD, when Red Hat Linux
attempts to load the Adaptec driver  (aic7xxx driver), the Adaptec chip
hangs during the Parallel Protocol Request.  During the Parallel Protocol
Request, we assert REQ for the REQ/ACK Offset of 3FH (63), however ACK is
never asserted by the initiator.
Why is the driver sending an Ultra 3 message?
Do you have an update Adaptec aix7xxxx driver?

Our previous generation drive, Ultrastar 18ES (SCSI Ultra 2) works fine w/
Linux 6.1, because we reject the Parallel Protocol Request.

Comment 1 bbetanco 2000-03-01 20:26:59 UTC
I could provide you a SCSI bus trace of issue.
Send request to bbetanco@us.ibm.com
BTW- you can call me Bill!

Comment 2 Cristian Gafton 2000-03-02 17:13:59 UTC
assigned to dledford

Comment 3 bbetanco 2000-03-02 17:48:59 UTC
Thank you for your help!
The latest aic7xxx driver solved the issue!

Comment 4 Glen Foster 2001-08-01 17:42:45 UTC
Closing at customer's request.


Note You need to log in before you can comment on or make changes to this bug.