Bug 990200 - Static Analysis cleanup of lower risk items
Static Analysis cleanup of lower risk items
Status: CLOSED UPSTREAM
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.9
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: RHQ 4.9
Assigned To: Mike Thompson
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 10:46 EDT by Mike Foley
Modified: 2013-08-01 09:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHQ 4.9.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 09:09:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2013-07-30 10:46:27 EDT
Description of problem:  OverviewForm.java:134, DLS_DEAD_LOCAL_STORE, Priority: High  




Additional info:

http://jenkins.jonqe.lab.eng.bos.redhat.com:9080/job/rhq-master-build-findbugs/19/findbugsResult/module.-496923596/


OverviewForm.java:134, DLS_DEAD_LOCAL_STORE, Priority: High
Dead store to notNullValidator in org.rhq.enterprise.gui.coregui.client.inventory.resource.detail.OverviewForm.buildForm(ResourceType)

This instruction assigns a value to a local variable, but the value is not read or used in any subsequent instruction. Often, this indicates an error, because the value computed is never used.

At the Static Code Analysis review meeting, MikeT stated he would like to address this.
Comment 1 Mike Thompson 2013-07-31 15:11:31 EDT
As this was such a small issue I have included most the: 
Category MALICIOUS_CODE - Type MS_SHOULD_BE_FINAL

http://jenkins.jonqe.lab.eng.bos.redhat.com:9080/job/rhq-master-build-findbugs/19/findbugsResult/module.-496923596/category.-1516912906/type.-1710921011/

This should cleanup the stats (and code) a bit. This stuff was not major but the report is technically correct. Mostly the portlet static factories that should have final static instances since they are static inner classes were scrubbed. And cleaner code is always good.



We should always strive for ways that objectively (via tools) tells us about our code quality.

This was committed to master with commit id: 300fe85.
Comment 2 Mike Foley 2013-08-01 09:09:51 EDT
These changes will be covered by automated tests, regression tests.  No specific QE tasks required.

Note You need to log in before you can comment on or make changes to this bug.