Bug 990208 - abrt should not use /tmp for archive creation or other file operations
abrt should not use /tmp for archive creation or other file operations
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18TmpOnTmpfs
  Show dependency treegraph
 
Reported: 2013-07-30 10:54 EDT by Karel Volný
Modified: 2013-09-14 20:54 EDT (History)
7 users (show)

See Also:
Fixed In Version: gnome-abrt-0.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-14 20:54:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-07-30 10:54:05 EDT
Description of problem:
Because of limited space in /tmp [1] the archive creation may fail.
Please do not use /tmp at all.

Version-Release number of selected component (if applicable):
abrt-2.1.5-1.fc19.x86_64

How reproducible:
always?

Steps to Reproduce:
1. use your system as usual; if that doesn't work for you as a reproducer step, just fill /tmp by other means like dd if=/dev/zero of=/tmp/somefile
2. use your system as usual ... now this will work for everyone, with zero space in /tmp, something will crash sooner or later
3. try to report the crash

Actual results:
abrt fails because it is unable to write to /tmp

like this:

--- Running analyze_CCpp ---
Souhlasíte s odesláním obrazu paměti? (ten může obsahovat citlivá data). Pokud bude vaše odpověď 'Ne', zásobník volání se vygeneruje lokálně. (to může mít za následek stažení velkého množství dat). 'YES'
Zjišťování nastavení serveru
Příprava archivu pro odeslání
xz: (stdout): Write error: Na zařízení není volné místo
tar: -: Zapsáno pouze 4096 z 10240 bajtů
tar: Error is not recoverable: exiting now
Nemohu vytvořit dočasný soubor v /tmp


Expected results:
abrt works

Additional info:
[1] https://fedoraproject.org/wiki/Features/tmp-on-tmpfs
Comment 1 Jakub Filak 2013-08-01 12:47:22 EDT
Patches submitted for review:
https://lists.fedorahosted.org/pipermail/crash-catcher/2013-August/005118.html
Comment 2 Jakub Filak 2013-08-02 06:15:20 EDT
Fixed in upstream git:

abrt
====
commit 21a3ac3885c5b4e4e0605e12ecd183c118ec1117
Author: Jakub Filak <jfilak@redhat.com>
Date:   Thu Aug 1 18:45:26 2013 +0200

    do not store potentially big data in /tmp
    
    Related to rhbz#990208
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>

libreport
=========
commit c4151fc2e0e540cfdd70b8efd9776753c28e5f2d
Author: Jakub Filak <jfilak@redhat.com>
Date:   Thu Aug 1 18:42:04 2013 +0200

    do not store potentially big data in /tmp
    
    Closes rhbz#990208
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>
Comment 3 Fedora Update System 2013-09-13 09:09:53 EDT
gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19
Comment 4 Fedora Update System 2013-09-13 22:39:47 EDT
Package gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.1-1.fc19 abrt-2.1.7-1.fc19 libreport-2.1.7-1.fc19 satyr-0.9-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16707/gnome-abrt-0.3.1-1.fc19,abrt-2.1.7-1.fc19,libreport-2.1.7-1.fc19,satyr-0.9-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-14 20:54:51 EDT
gnome-abrt-0.3.1-1.fc19, abrt-2.1.7-1.fc19, libreport-2.1.7-1.fc19, satyr-0.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.