Bug 990213 - startx contains empty line before the #! line
Summary: startx contains empty line before the #! line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit
Version: 19
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1072051 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-30 15:04 UTC by Göran Uddeborg
Modified: 2014-09-23 05:01 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-xinit-1.3.4-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-14 03:26:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Göran Uddeborg 2013-07-30 15:04:56 UTC
Description of problem:
The file /usr/bin/startx contains a number of empty lines before the so called shebang, the line starting with #!.  This makes execve() fail on this command, the #! has to be on the first line.

Version-Release number of selected component (if applicable):
/xorg-x11-xinit-1.3.2-8.fc19

Additional info:
When run from a shell, this is pretty harmless.  The shell will start a bash on its own when the execve() fails.  But if one for example use /usr/bin/startx as the ExecStart command in a systemd.service file, it will not be as forgiving as the shell.  Rather it will report

  Failed at step EXEC spawning /usr/bin/startx: Exec format error

And the service will fail.

(In case you wonder: we use startx to bring up mythfrontend in a MythTV box.)

Comment 1 Hans de Goede 2014-09-11 14:38:29 UTC
*** Bug 1072051 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2014-09-12 07:12:55 UTC
xorg-x11-xinit-1.3.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/xorg-x11-xinit-1.3.4-1.fc21

Comment 3 Fedora Update System 2014-09-12 07:14:26 UTC
xorg-x11-xinit-1.3.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xorg-x11-xinit-1.3.4-1.fc20

Comment 4 Fedora Update System 2014-09-12 17:47:16 UTC
Package xorg-x11-xinit-1.3.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-xinit-1.3.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10768/xorg-x11-xinit-1.3.4-1.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-09-14 03:26:39 UTC
xorg-x11-xinit-1.3.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2014-09-23 05:01:45 UTC
xorg-x11-xinit-1.3.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.