Bug 990222 - qemu-kvm crashes when plugging 161th vCPU
qemu-kvm crashes when plugging 161th vCPU
Status: CLOSED DUPLICATE of bug 989439
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 11:33 EDT by Peter Krempa
Modified: 2013-07-31 04:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 03:38:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Krempa 2013-07-30 11:33:04 EDT
Description of problem:
qemu-kvm crashes when trying to hotplug the 161th cpu.


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.382.el6.x86_64
libvirt-0.10.2-21.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. start a guest with 1 actual cpu and 161+ possible vCPUs
when using libvirt:
<vcpu placement='static' current='1'>162</vcpu>

2. hotplug 160 more cpus into the guest
when using libvirt-0.10.2-21.el6.x86_64 (this version has the limit of maximum cpus removed)

virsh setvcpus --live domainname 161

or

use monitor manually.

3. qemu-kvm exits on signal 6

Actual results:
qemu-kvm crashes

Expected results:
qemu-kvm will reject hotplug of the cpu with an error


Additional info:
Core was generated by `/usr/libexec/qemu-kvm -name asdf -S -M rhel6.5.0 -enable-kvm -m 1024 -realtime'.
Program terminated with signal 6, Aborted.
#0  0x00007f2c483f28d5 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);

(gdb) bt
#0  0x00007f2c483f28d5 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007f2c483f40b5 in abort () at abort.c:92
#2  0x00007f2c4aae0ffb in kvm_create_vcpu (_env=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:475
#3  ap_main_loop (_env=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2026
#4  0x00007f2c4a4139d1 in start_thread (arg=0x7f2b5f371700) at pthread_create.c:301
#5  0x00007f2c484a8a3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

(full backtrace has a lot of threads waiting in do_sigtimedwait, I can attach it if needed)
Comment 2 Qunfang Zhang 2013-07-30 23:24:59 EDT
Hi, Peter
FYI, this bug should be the same issue with bug 989439 which is closed as WONTFIX.
Comment 3 Peter Krempa 2013-07-31 03:38:34 EDT
(In reply to Qunfang Zhang from comment #2)
> Hi, Peter
> FYI, this bug should be the same issue with bug 989439 which is closed as
> WONTFIX.

Hmm, right. Bugzilla didn't show it as a possible duplicate. As libvirt won't support hotplugging more than 160 cpus in rhel 6 I'm closing this as a duplicate of said bug.

*** This bug has been marked as a duplicate of bug 989439 ***

Note You need to log in before you can comment on or make changes to this bug.