Bug 990239 - RFE - As a SAM customer, I should be able to select the instance based subscriptions only in increments of 2
RFE - As a SAM customer, I should be able to select the instance based subscr...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
: FutureFeature
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-07-30 11:56 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:15:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Instance based subscription incremented by 2 (74.15 KB, image/png)
2013-09-13 16:36 EDT, sthirugn@redhat.com
no flags Details
Subscription used (48.80 KB, image/png)
2013-09-13 16:36 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-07-30 11:56:03 EDT
Description of problem:
RFE - As a SAM customer, I should be able to select the instance based subscriptions only in increments of 2

Version-Release number of selected component (if applicable):
N/A

How reproducible:
N/A

Steps to Reproduce:
1. Install SAM
2. Download a manifest (say, a manifest containing instance based subscriptions)
3. Register and Subscribe a physical system
4. Navigate to SAM UI -> Systems -> Select the System -> Try to attach the available instance based subscriptions

Actual results:
Now the user should know that he needs 2 instance based subscriptions to make the physical system green

Expected results:
The user should be allowed to select the instance based subsriptions only in increments of 2


Additional info:
Comment 2 Bryan Kearney 2013-08-28 13:17:45 EDT
Please retest with Snap4.
Comment 3 sthirugn@redhat.com 2013-09-13 16:35:35 EDT
Verified. Now I see the instance based subscriptions incrementing by 2. (Relevant screenshots attached)
 
Version Tested:
* candlepin-0.8.26-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.26-1.el6sam.noarch
* candlepin-tomcat6-0.8.26-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-10.el6sat.noarch
* katello-cli-common-1.4.3-10.el6sat.noarch
* katello-common-1.4.3-13.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-13.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-13.el6sam_splice.noarch
* katello-headpin-1.4.3-13.el6sam_splice.noarch
* katello-headpin-all-1.4.3-13.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch
Comment 4 sthirugn@redhat.com 2013-09-13 16:36:18 EDT
Created attachment 797527 [details]
Instance based subscription incremented by 2
Comment 5 sthirugn@redhat.com 2013-09-13 16:36:42 EDT
Created attachment 797528 [details]
Subscription used
Comment 7 errata-xmlrpc 2013-10-01 07:15:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.