Bug 990254 - qemu-kvm failing when invalid machine type is provided
qemu-kvm failing when invalid machine type is provided
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: 6.5
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On:
Blocks: 990724
  Show dependency treegraph
 
Reported: 2013-07-30 13:05 EDT by Michal Novotny
Modified: 2014-10-14 02:49 EDT (History)
11 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.429.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 990724 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:49:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Novotny 2013-07-30 13:05:31 EDT
Description of problem:
When user starts qemu-kvm with invalid (unsupported) machine type, only the list of supported machines is being output back to the user without any information the machine type specified is invalid.

Version-Release number of selected component (if applicable):
any

How reproducible:
100%

Steps to Reproduce:
1. /usr/lib/qemu-kvm -M error
2.
3.

Actual results:
$ qemu-kvm -M ?
Supported machines are:
pc         Standard PC (alias of $SOMETHING)
...

Expected results:
$ qemu-kvm -M ?
Error: Unsupported machine type 'error'
Supported machines are:
pc         Standard PC (alias of $SOMETHING)
...

Additional info:
Patch posted upstream. Details at http://lists.nongnu.org/archive/html/qemu-devel/2013-07/msg05884.html .
Comment 6 Miroslav Rezanina 2014-07-04 03:10:11 EDT
Fix included in qemu-kvm-0.12.1.2-2.429.el6
Comment 8 Shaolong Hu 2014-07-14 03:17:47 EDT
With qemu 428:

[root@localhost ~]# /usr/libexec/qemu-kvm -M error
Supported machines are:
pc         RHEL 6.5.0 PC (alias of rhel6.5.0)
rhel6.5.0  RHEL 6.5.0 PC (default)
rhel6.4.0  RHEL 6.4.0 PC
rhel6.3.0  RHEL 6.3.0 PC
rhel6.2.0  RHEL 6.2.0 PC
rhel6.1.0  RHEL 6.1.0 PC
rhel6.0.0  RHEL 6.0.0 PC
rhel5.5.0  RHEL 5.5.0 PC
rhel5.4.4  RHEL 5.4.4 PC
rhel5.4.0  RHEL 5.4.0 PC

With 429:

[root@localhost ~]# /usr/libexec/qemu-kvm -M error
qemu-kvm: -M error: Unsupported machine type
Use -M ? to list supported machines!
Comment 9 errata-xmlrpc 2014-10-14 02:49:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html

Note You need to log in before you can comment on or make changes to this bug.