This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 990258 - libguestfs: error: could not create appliance through libvirt: XML error: No PCI buses available [code=27 domain=10]
libguestfs: error: could not create appliance through libvirt: XML error: No ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker TRACKER-bugs-affecting-libguestfs
  Show dependency treegraph
 
Reported: 2013-07-30 13:28 EDT by Richard W.M. Jones
Modified: 2013-08-30 18:04 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 18:04:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (166.03 KB, text/plain)
2013-07-30 13:29 EDT, Richard W.M. Jones
no flags Details
build.log (1.87 MB, text/plain)
2013-07-30 13:30 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2013-07-30 13:28:29 EDT
Description of problem:

libguestfs cannot create domains on armv7hl.  See the attached
log file.

Version-Release number of selected component (if applicable):

Fedora Rawhide.  For the precise versions of everything, please
see the attached root.log file.

How reproducible:

100%

Steps to Reproduce:
1. 'make check' in libguestfs sources on armv7hl

Actual results:

See attached build.log file.
Comment 1 Richard W.M. Jones 2013-07-30 13:29:34 EDT
Created attachment 780765 [details]
root.log
Comment 2 Richard W.M. Jones 2013-07-30 13:30:24 EDT
Created attachment 780770 [details]
build.log
Comment 3 Richard W.M. Jones 2013-07-30 13:31:24 EDT
Taking this bug, since plausibly it's a problem with the
XML that we are passing to libvirt.  In any case, I'm
upgrading a couple of ARM machines to Fedora 19 so I can
investigate the problem further.
Comment 4 Daniel Berrange 2013-07-30 14:54:45 EDT
Use of ARM guests is known to be broken, with the fix targetted for F20

https://fedoraproject.org/wiki/Changes/Virt_ARM_on_x86
Comment 5 Dennis Gilmore 2013-07-30 15:41:43 EDT
most ARM systems do not have a pci bus at all. if libvirt assumes that there always is a pci bus it is wrong
Comment 6 Laine Stump 2013-07-30 16:18:21 EDT
(In reply to Dennis Gilmore from comment #5)
> most ARM systems do not have a pci bus at all. if libvirt assumes that there
> always is a pci bus it is wrong

Yes, we're (painfully) aware of that. Historically libvirt had many assumptions about the "pc" (Intel i440fx chipset) machinetype built into it (artifacts of the days when that was the only machinetype anyone using libvirt was interested in), and we are now working to remove those (that's much of the work for the F20 feature Dan pointed out). (This is also a problem for the q35 machinetype, and many others as well).
Comment 7 Cole Robinson 2013-07-31 10:20:45 EDT
FYI I'm posting a libvirt patch series today which allows kicking off qemu-system-arm guests. It isn't exhaustive so it may not cover libguestfs, but it makes certain configurations possible, where currently none are possible.
Comment 8 Peter Robinson 2013-07-31 12:19:56 EDT
There's also a patch set for virtio-mmio support for qemu as well which is useful/needed for HW virt on ARM

http://lists.nongnu.org/archive/html/qemu-devel/2013-06/msg04920.html
Comment 9 Richard W.M. Jones 2013-07-31 12:51:52 EDT
(In reply to Peter Robinson from comment #8)
> There's also a patch set for virtio-mmio support for qemu as well which is
> useful/needed for HW virt on ARM
> 
> http://lists.nongnu.org/archive/html/qemu-devel/2013-06/msg04920.html

virtio-mmio is pretty much essential for libguestfs.  Reading
the feedback on that patch series is not encouraging at all.
Comment 10 Richard W.M. Jones 2013-07-31 12:55:10 EDT
(In reply to Richard W.M. Jones from comment #9)
> (In reply to Peter Robinson from comment #8)
> > There's also a patch set for virtio-mmio support for qemu as well which is
> > useful/needed for HW virt on ARM
> > 
> > http://lists.nongnu.org/archive/html/qemu-devel/2013-06/msg04920.html
> 
> virtio-mmio is pretty much essential for libguestfs.  Reading
> the feedback on that patch series is not encouraging at all.

Well I take that back, because in fact it *did* end upstream
(just 4 days ago).
Comment 11 Cole Robinson 2013-08-30 18:04:57 EDT
My patches are in rawhide, which drops the PCI assumption for all ARM. libguestfs/libvirt likely still needs more work to fix launching the libguestfs appliance, but this particular error message is fixed.

Note You need to log in before you can comment on or make changes to this bug.