Bug 990294 - access to form data for human tasks using REST api's
access to form data for human tasks using REST api's
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER1
: 6.0.1
Assigned To: Marco Rietveld
Tomas Livora
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 15:55 EDT by smahajan@redhat.com
Modified: 2016-09-20 01:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:03:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Task form XML and screenshots. (196.42 KB, application/zip)
2013-07-30 15:55 EDT, smahajan@redhat.com
no flags Details

  None (edit)
Description smahajan@redhat.com 2013-07-30 15:55:49 EDT
Created attachment 780825 [details]
Task form XML and screenshots.

Yavuz, from mobile computing team is building an iPhone application, which process stakeholders can use to complete tasks in their workflow. The application uses the RESTFUL APIs to pull task data from the task server.

Currently when the iPhone app queries the task server, to lookup task information for a particular user (e.g. Mary, HR the first stakeholder in the HR hiring process) we get the below XML.

But we do not get any information about the form fields {Candidate Name, Age, E-Mail, Score}, type {Text field, drop down field}  and it’s data {Shankar, 25, spalakodeti@gmail.com, 5-Excellent}. We would need this data to be exposed by the REST api’s for the iPhone app to dynamically generate the process form for different processes.

Following screenshots are attached for reference.

1) query_mary.xml: XML returned for user(mary) when queried for tasks in task server.
2) HR_Hiring_Process: Business process for HR Hiring.
3) HR_Interview_Form: Task form that mary fills to complete its task.
Comment 2 Mauricio Salatino 2013-07-31 04:08:47 EDT
In order to get this information from the current services the BPMN2DataServices needs to be exposed via REST
Comment 3 Marco Rietveld 2013-08-06 12:02:04 EDT
Fixed, but not set to modified because I do not know what the target milestone is. 

Content jaxb serialization implementation commit: 
https://github.com/droolsjbpm/jbpm/commit/ee02542c146c696bd0ef589147d4ad52e8106189

TaskResource REST operations commit: 
https://github.com/droolsjbpm/droolsjbpm-integration/commit/8c6d56d826eac0ddd446e714c2a15a973ab8f9a4

There has been some further discussion about the issue, in particular with regards to making the accesibility of the (serialized) content more accesible for clients that should not need to deserialize the content byte []. This operation may evolve further.
Comment 4 smahajan@redhat.com 2013-08-06 12:31:03 EDT
Hi Marco,

Can you please provide us the documentation for the fix.
As of now we are using this documentation to access the RESTFUL APIs

https://github.com/mrietveld/droolsjbpm-integration/wiki/Rest-API

and use the methods described in this to do the required actions.

E.g. To list the tasks for a potential owner:
http://localhost:8080/business-central/rest/task/query?potentialOwner=admin

Shishir
Comment 5 Lukáš Petrovický 2014-01-27 11:39:27 EST
Per comment 3, this is ready for pickup.
Comment 7 Marek Baluch 2014-02-20 10:24:25 EST
VERIFIED on 6.0.1-ER1

Note You need to log in before you can comment on or make changes to this bug.