Bug 990295 - Navigation Bar - Project Explorer Updates : Per Mike Anstis
Navigation Bar - Project Explorer Updates : Per Mike Anstis
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
All All
high Severity high
: ER5
: 6.0.0
Assigned To: Alexandre Porcelli
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 15:58 EDT by Prakash Aradhya
Modified: 2014-08-06 16:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:15:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Project Explorer Design (with interaction notes) (449.18 KB, application/pdf)
2013-08-02 14:24 EDT, Joe Sniezek
no flags Details
Project Explorer Business View (Community CR4) (32.40 KB, image/png)
2013-09-11 16:27 EDT, manstis
no flags Details
Latest version of Project Explorer (68.57 KB, image/png)
2013-09-18 15:59 EDT, Joe Sniezek
no flags Details

  None (edit)
Description Prakash Aradhya 2013-07-30 15:58:04 EDT
Description of problem:
Here are the updates we discussed today.  Joe, please feel free to add wireframes to the bug.

- Project Explorer name should be updated to "


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Joe Sniezek 2013-08-02 14:24:12 EDT
Created attachment 782119 [details]
Project Explorer Design (with interaction notes)
Comment 6 manstis 2013-09-11 16:27:50 EDT
Created attachment 796504 [details]
Project Explorer Business View (Community CR4)
Comment 7 Joe Sniezek 2013-09-13 10:42:42 EDT
Hi manstis,

Thanks for working towards improvements in the explorer, and I apologize that the previous designs were underdeveloped.

Now that I understand how things work behind the scenes a little better, I can see that ignoring repos and packages doesn't make sense.  The intention was to shield business users from dev-oriented concepts (packages and repos), but that is probably impossible at the moment.

Given these constraints, there are still some improvement that can be made. The main issue with the current implementation is the use of 4 drop-downs for selecting a context.  While its certainly an interesting approach, it's confusing for general users, and it's inefficient.

I do have another mock-up idea, with a tree view inside the second drop-down (the one that currently says "all projects").  This approach would enable us to view the Repo/Projects/Packages structure, and select a level of context for viewing assets.  I believe this might be the best way of doing things, because it satisfies the needs for efficiency, full exploration of the (design-side) folder structure, and enough of a differentiation from the technical view so as not to confuse users who might traverse both domains (hopefully).

I will provide an updated design soon.  Catherine and I are working on an updated homepage as well.  We should probably also do a hangout to discuss things.
Comment 8 Prakash Aradhya 2013-09-16 15:01:18 EDT
Mike and team,
This is the highest priority for the Beta.
Please get this resolved at the earliest.
We really need to use the design interface for navigation as put into this bugzilla.  It needs to be really intuitive and simple for business users to navigate through assets.

thanks
Comment 10 Mark Proctor 2013-09-18 00:01:35 EDT
Something else to consider. The "business" files view actually combines files across 4 paths (4 different tree folders):
src/main/java
src/main/resources
src/test/java
src/test/resources

The "technical" view does not combine those, each is a separate navigation.

Any UI needs to reconcile these two aspects.
Comment 11 Joe Sniezek 2013-09-18 10:45:19 EDT
Hi Mark, thanks for the information.  

My thoughts on this are the following:
The current business view contains 4 drop-downs for depicting the (simplified) hierarchy of Group, Repo, Project, and Package.  I assume that this is doing some work behind the scenes of pulling together appropriate items from the 4 underlying tree folders (correct me if I am wrong).  A tree-view version of the simplified hierarchy would be representing the same information, and could thus do the same behind-the-scenes aggregation.

On the flip side, there is the issue of asset creation in the business view: if we were to have a way for the user to add a business item to a package from within the simplified hierarchy, can we automatically store it in the right place in the underlying structure?  In other words, is there a rule for where assets go based on asset type, or does it depend on other factors?
Comment 12 Joe Sniezek 2013-09-18 15:59:22 EDT
Created attachment 799586 [details]
Latest version of Project Explorer

Latest Design for the Project Explorer. Comments welcome.

Notes:
"Organization" drop-down contains Groups and Repos.  Business user will select a repo from the list, but not a group directly.
"Projects" Section contains all projects and packages within a repo, shown as a folder structure.  
Folders and packages will have a righthand 'actions' drop-down with the following options: "Properties...", "Rename", "Copy" (or "Duplicate"), and "Delete".  We need to discuss the Copy/Paste capabilities of the tool (and what can be done in the timeframe we have).  
"Assets" view has been moved to a primary panel.  This panel will show assets within selected project and below.  This panel will also appear in the drop-down of active panels at the right side of the screen (and always as the first item).  There will only every be one asset panel.  The title of the asset panel will be [Project] or [Project / Package] as appropriate.  Clicking on an asset will open up that assets editor in a primary panel.  Clicking on a folder in the project hierarchy will open the asset panel showing that folder's content (in the way described above).
The "technical" explorer will only be accessible in the Authoring->Administration view.

I think that's it for this view.

Note You need to log in before you can comment on or make changes to this bug.