Bug 990297 - Regression: Failure to display some decrypted GPG messages
Regression: Failure to display some decrypted GPG messages
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 16:07 EDT by Kai Engert (:kaie)
Modified: 2013-07-31 05:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 05:09:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 705194 None None None Never

  None (edit)
Description Kai Engert (:kaie) 2013-07-30 16:07:58 EDT
Worked in Evolution 3.8.3 packages, but fails in 3.8.4 packages.

The problem occurrs with GPG encrypted messages, that aren't nested, and use a plain text content-type (or absent content type). In other words, messages where the body consists of
-----BEGIN PGP MESSAGE-----
...
-----END PGP MESSAGE-----
only.

Such messages are displayed with an "encrypted" status icon and a text attachments.

Problem: When clicking "view inline", nothing happens, no decrypted content shown.

With the older evolution 3.8.3 packages, the decrypted content is shown.
Comment 1 Milan Crha 2013-07-31 05:09:52 EDT
Thanks for a bug report. I can reproduce it too. I do not know what caused it, yet. I'm moving this upstream, because it's not Fedora specific issue.
Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=705194

Note You need to log in before you can comment on or make changes to this bug.