Bug 990314 - cannot create an app based on PHP5.3
cannot create an app based on PHP5.3
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 17:27 EDT by Andrew Starlike
Modified: 2015-05-14 22:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-30 19:08:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Starlike 2013-07-30 17:27:45 EDT
I'm trying to create an app using the Management Console.

At step 1 i choose PHP 5.3,

at step 2 i insert the public url, github link to source code, gears small, cartriges PHP 5.3 and no scalling.

After i press the button Create Application i wait a few moments and i receive the folowing error:

The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 51f82de7500446ee55000003 -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c2,c660' /bin/sh -c \"gear postreceive >> /tmp/initial-build.log 2>&1\""' returned an error. rc=255 .Last 10 kB of build output: Syntax error on line 2 of /var/lib/openshift/51f82de7500446ee55000003/php/configuration/etc/conf.d/openshift.conf: DocumentRoot must be a directory httpd (no pid file) not running Syntax error on line 2 of /var/lib/openshift/51f82de7500446ee55000003/php/configuration/etc/conf.d/openshift.conf: DocumentRoot must be a directory An error occurred executing 'gear postreceive' (exit code: 1) Error message: Failed to execute: 'control start' for /var/lib/openshift/51f82de7500446ee55000003/php For more details about the problem, try running the command again with the '--trace' option.
Comment 1 Dan McPherson 2013-07-30 19:08:15 EDT
The issue is the app you are pointing to doesn't have a php directory.  OpenShift php apps need to have the app content rooted at php/

Ex:

https://github.com/openshift/cakephp-example

Note You need to log in before you can comment on or make changes to this bug.