Bug 990331 - geo-replication fails for longer fqdn's
geo-replication fails for longer fqdn's
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Ajeet Jha
M S Vishwanath Bhat
: ZStream
Depends On: 990330
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 20:00 EDT by Harshavardhana
Modified: 2016-05-31 21:56 EDT (History)
12 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.50rhs
Doc Type: Bug Fix
Doc Text:
Previously, SSH failed on a hostname which had its Fully Qualified Domain Name(FQDN) longer than 45 characters. With this fix, Geo-replication does not fail due to a lengthy FQDN.
Story Points: ---
Clone Of: 990330
Environment:
Last Closed: 2014-02-25 02:34:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Amar Tumballi 2013-09-05 03:02:42 EDT
Harsha, do you think it is critical to have http://review.gluster.org/5681 backported to rhs-2.1 branch by Update1 (need flag 'rhs-2.1.z' for that) Or would it wait for Corbett?
Comment 6 Harshavardhana 2013-10-07 13:13:08 EDT
(In reply to Amar Tumballi from comment #5)
> Harsha, do you think it is critical to have http://review.gluster.org/5681
> backported to rhs-2.1 branch by Update1 (need flag 'rhs-2.1.z' for that) Or
> would it wait for Corbett?

I don't see this to be critical, since it wasn't reproduced at customer site. Corbett would be good enough.
Comment 8 M S Vishwanath Bhat 2014-01-03 05:40:12 EST
This is working now.

Tested in version: glusterfs-3.4.0.53rhs-1.el6rhs.x86_64

[root@pythagoras ]# gluster v geo master euclid-380pgen8-05.osas.lab.eng.rdu2.redhat.com::slave status detail
 
MASTER NODE                  MASTER VOL    MASTER BRICK          SLAVE                                                      STATUS     CHECKPOINT STATUS    CRAWL STATUS       FILES SYNCD    FILES PENDING    BYTES PENDING    DELETES PENDING    FILES SKIPPED   
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
pythagoras.blr.redhat.com    master        /rhs/bricks/brick0    euler-380pgen8-05.osas.lab.eng.rdu2.redhat.com::slave      Active     N/A                  Changelog Crawl    16191          0                0                0                  0               
archimedes.blr.redhat.com    master        /rhs/bricks/brick3    gauss-380pgen8-05.osas.lab.eng.rdu2.redhat.com::slave      Passive    N/A                  N/A                0              0                0                0                  0               
aryabhatta.blr.redhat.com    master        /rhs/bricks/brick1    euclid-380pgen8-05.osas.lab.eng.rdu2.redhat.com::slave     Passive    N/A                  N/A                0              0                0                0                  0               
ramanujan.blr.redhat.com     master        /rhs/bricks/brick2    riemann-380pgen8-05.osas.lab.eng.rdu2.redhat.com::slave    Active     N/A                  Changelog Crawl    16582          0                0                0                  0               


I used longer fqdn's than the one's used in first comment. And I didn't find any errors in the geo-rep logs.

[root@pythagoras ]# egrep "\ E\ " /var/log/glusterfs/geo-replication/master/ssh%3A%2F%2Froot%4010.70.37.188%3Agluster%3A%2F%2F127.0.0.1%3Aslave.*
[root@pythagoras ]# 

Moving the bug to verified.
Comment 10 Harshavardhana 2014-01-06 14:14:09 EST
Ah sorry for the noise the change is not this one but - bug 1019522, moving this back to verified
Comment 11 Pavithra 2014-01-08 02:13:05 EST
Can you please verify the technical accuracy of the doc text?
Comment 13 errata-xmlrpc 2014-02-25 02:34:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.